<!doctype html>
      <html class="single desktop logo-above-nav fixed-full-width" lang="en">
        <head>
          <title data-react-helmet="true">Bandcamp exclusives for today’s fundraiser (Sonic Youth, Death Cab, Swervedriver, Merge comp, more)</title>
          <meta data-react-helmet="true" http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta data-react-helmet="true" charset="UTF-8"/><meta data-react-helmet="true" name="instagram_profile" value="BrooklynVegan"/><meta data-react-helmet="true" name="description" content="Plus: Swervedriver, The Mountain Goats, Lingua Ignota, Lucy Dacus, Charly Bliss, Wylde Ratttz (Sonic Youth, Stooges, Minutemen), Petrol Girls, Fleet Foxes, Lakes (Glassjaw cover), and more."/><meta data-react-helmet="true" name="keywords" content="music news"/><meta data-react-helmet="true" property="fb:app_id" content="598461367435921"/><meta data-react-helmet="true" property="fb:admins" content="100002025987268"/><meta data-react-helmet="true" property="fb:admins" content="590999851"/><meta data-react-helmet="true" property="fb:admins" content="100000461628108"/><meta data-react-helmet="true" property="fb:admins" content="732998853"/><meta data-react-helmet="true" property="og:title" content="Bandcamp exclusives for today’s fundraiser (Sonic Youth, Death Cab, Swervedriver, Merge comp, more)"/><meta data-react-helmet="true" property="og:description" content="Plus: Swervedriver, The Mountain Goats, Lingua Ignota, Lucy Dacus, Charly Bliss, Wylde Ratttz (Sonic Youth, Stooges, Minutemen), Petrol Girls, Fleet Foxes, Lakes (Glassjaw cover), and more."/><meta data-react-helmet="true" property="og:url" content="https://www.brooklynvegan.com/bandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more/"/><meta data-react-helmet="true" property="og:site_name" content="BrooklynVegan"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" property="og:image" content="https://townsquare.media/site/838/files/2020/12/sonic-youth-live-in-copenhagen.jpg?w=1200&amp;h=0&amp;zc=1&amp;s=0&amp;a=t&amp;q=89"/><meta data-react-helmet="true" property="og:image:width" content="1200"/><meta data-react-helmet="true" property="og:image:height" content="630"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:site" content="@brooklynvegan"/><meta data-react-helmet="true" http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta data-react-helmet="true" name="viewport" content="width=1286, initial-scale=1.0"/><meta data-react-helmet="true" name="robots" content="max-image-preview:large"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=faac599aae36a1b9701b044d93ab8f550b9cf1a3&mver=122" as="style"/>
          <link data-react-helmet="true" id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/838/files/2016/02/favicon.gif"/><link data-react-helmet="true" rel="profile" href="http://gmpg.org/xfn/11"/><link data-react-helmet="true" rel="prev" title="Watch Miley Cyrus cover Hole’s “Doll Parts” on ‘Howard Stern’" href="https://www.brooklynvegan.com/watch-miley-cyrus-cover-holes-doll-parts-on-howard-stern/"/><link data-react-helmet="true" rel="next" title="Notable Releases of the Week (12/4)" href="https://www.brooklynvegan.com/rico-nasty-respire-your-old-droog-clearbody-moore-family-band-reviews/"/><link data-react-helmet="true" rel="canonical" href="https://www.brooklynvegan.com/bandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more/"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" href="https://townsquare.media/site/838/files/2016/02/57.jpg"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/site/838/files/2016/02/114.jpg"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="72x72" href="//townsquare.media/site/838/files/2016/02/72.jpg"/>
          <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" />
          <link href="/styles/desktop/base.css?ver=faac599aae36a1b9701b044d93ab8f550b9cf1a3&mver=122" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "A";
          window.TSM.cadata = {"activeDomain":"www.brooklynvegan.com","blogId":838,"method":"get_single","postId":518796,"postType":"post","postDateGmt":"2020-12-04 14:16:20.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"brooklynvegan","dimension2":"music","dimension3":"ajj,anjimile,b-52s,bandcamp,best-ex,bill-mackay,camp-blood,cat-power,charly-bliss,chris-farren,cinema-stare,cliffdiver,cloaker,community-records,corrupt-vision,dan-potthast,death-cab-for-cutie,dominic-minix,fleet-foxes,fruit-bats,geoff-rickly,gilt,glassjaw,godthrymm,hard-girls,hate-club,hinder,hiss-golden-messenger,hornbill,illuminati-hotties,indigo-girls,into-it-over-it,jaime-brooks,jeff-rosenstock,jersey-interchange,johanna-warren,josh-homme,karl-blau,ken-vandermark,lakes,lala-lala,laughingstock,lingua-ignota,lucy-dacus,macseal,michael-malarkey,mike-hugenor,mount-eerie,nathan-salsburg,nessa,nnamdi,no-better,oceantor,odd-robot,ogikubo-station,ohmme,otis-redding,p-s-youredead,palette-knife,pet-symmetry,petrol-girls,pink-navel,pom-pom-squad,post-animal,pronoun,pylon,queen-of-jeans,radical-dads,ramonda-hammer,ratboys,rem,riverby,rosie-tucker,routine,sad13,sarah-and-the-safe-word,sean-bonnette,sidney-gish,sonic-youth,spectral-voice,superchunk,swervedriver,the-casket-lottery,the-mountain-goats,the-weekend-run-club,this-white-light,titus-andronicus,to-be-gentle,torres,two-minutes-to-late-night,will-butler,wye-oak,you-me-and-everyone-we-know,zola-jesus","dimension4":"post","dimension5":"Fri Dec 04 2020","dimension6":"09:16","dimension7":"standard","dimension8":"1160","dimension9":"A","dimension10":"no","dimension12":"","dimension13":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
window.globalDimensionData = {"dimension1":"brooklynvegan","dimension2":"music","dimension3":"ajj,anjimile,b-52s,bandcamp,best-ex,bill-mackay,camp-blood,cat-power,charly-bliss,chris-farren,cinema-stare,cliffdiver,cloaker,community-records,corrupt-vision,dan-potthast,death-cab-for-cutie,dominic-minix,fleet-foxes,fruit-bats,geoff-rickly,gilt,glassjaw,godthrymm,hard-girls,hate-club,hinder,hiss-golden-messenger,hornbill,illuminati-hotties,indigo-girls,into-it-over-it,jaime-brooks,jeff-rosenstock,jersey-interchange,johanna-warren,josh-homme,karl-blau,ken-vandermark,lakes,lala-lala,laughingstock,lingua-ignota,lucy-dacus,macseal,michael-malarkey,mike-hugenor,mount-eerie,nathan-salsburg,nessa,nnamdi,no-better,oceantor,odd-robot,ogikubo-station,ohmme,otis-redding,p-s-youredead,palette-knife,pet-symmetry,petrol-girls,pink-navel,pom-pom-squad,post-animal,pronoun,pylon,queen-of-jeans,radical-dads,ramonda-hammer,ratboys,rem,riverby,rosie-tucker,routine,sad13,sarah-and-the-safe-word,sean-bonnette,sidney-gish,sonic-youth,spectral-voice,superchunk,swervedriver,the-casket-lottery,the-mountain-goats,the-weekend-run-club,this-white-light,titus-andronicus,to-be-gentle,torres,two-minutes-to-late-night,will-butler,wye-oak,you-me-and-everyone-we-know,zola-jesus","dimension4":"post","dimension5":"Fri Dec 04 2020","dimension6":"09:16","dimension7":"standard","dimension8":"1160","dimension9":"A","dimension10":"no","dimension12":"","dimension13":""};
ga( "create", {
          trackingId:"UA-1165436-1",
          name: "primary",
          allowAnchor: false
        });
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-1165436-1"};
            })(window);
          </script>
          <script async src="https://www.google-analytics.com/analytics.js"></script>
          <script async src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Bandcamp exclusives for today’s fundraiser (Sonic Youth, Death Cab, Swervedriver, Merge comp, more)","callsign":"BrooklynVegan","market":"National","sitetype":"Partner","siteClassification":"","state":"NY","genre":"indie-alternative","pageType":"post","tags":"ajj,anjimile,b-52s,bandcamp,best-ex,bill-mackay,camp-blood,cat-power,charly-bliss,chris-farren,cinema-stare,cliffdiver,cloaker,community-records,corrupt-vision,dan-potthast,death-cab-for-cutie,dominic-minix,fleet-foxes,fruit-bats,geoff-rickly,gilt,glassjaw,godthrymm,hard-girls,hate-club,hinder,hiss-golden-messenger,hornbill,illuminati-hotties,indigo-girls,into-it-over-it,jaime-brooks,jeff-rosenstock,jersey-interchange,johanna-warren,josh-homme,karl-blau,ken-vandermark,lakes,lala-lala,laughingstock,lingua-ignota,lucy-dacus,macseal,michael-malarkey,mike-hugenor,mount-eerie,nathan-salsburg,nessa,nnamdi,no-better,oceantor,odd-robot,ogikubo-station,ohmme,otis-redding,p-s-youredead,palette-knife,pet-symmetry,petrol-girls,pink-navel,pom-pom-squad,post-animal,pronoun,pylon,queen-of-jeans,radical-dads,ramonda-hammer,ratboys,rem,riverby,rosie-tucker,routine,sad13,sarah-and-the-safe-word,sean-bonnette,sidney-gish,sonic-youth,spectral-voice,superchunk,swervedriver,the-casket-lottery,the-mountain-goats,the-weekend-run-club,this-white-light,titus-andronicus,to-be-gentle,torres,two-minutes-to-late-night,will-butler,wye-oak,you-me-and-everyone-we-know,zola-jesus","categories":"music","mediaType":"video"}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");});</script>
          <script>
        window.taskQ=window.taskQ||[];window.taskQ.push(function(){
          (function(w,dl){
            var
              isUS = RegExp( "us-region-source=CA" ).exec( document.cookie );
            const
              addOipScript = function(){
                if( dl && dl[0] ){
                  dl = dl[0];
                  w._oiqq = w._oiqq || [];
                  var keywordMeta = document.querySelector( "meta[name='keywords']");
                  _oiqq.push(["oiq_addPageBrand", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageBrand", "domain:" + location.hostname]);
                  _oiqq.push(["oiq_addPageBrand", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "url_path:" + location.pathname]);
                  _oiqq.push(["oiq_addPageCat", "meta_keywords:" + ( keywordMeta ? keywordMeta.content : "" ) ]);
                  _oiqq.push(["oiq_addPageCat", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageCat", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "market:" + dl.market]);
                  _oiqq.push(["oiq_addPageCat", "sitetype:" + dl.sitetype]);
                  _oiqq.push(["oiq_addPageCat", "state:" + dl.state]);
                  _oiqq.push(["oiq_addPageCat", "page_type:" + dl.pageType]);
                  _oiqq.push(["oiq_addPageCat", "media_type:" + dl.mediaType]);
                  _oiqq.push(["oiq_addPageCat", "day_of_week:" + dl.dayOfWeek]);
                  _oiqq.push(["oiq_addPageCat", "newsletter_submission:" + (dl.newsletterSubmission || "no")]);
                  _oiqq.push(["oiq_addPageCat", "period_of_day:" + dl.periodOfDay]);
                  _oiqq.push(["oiq_addPageCat", "curated_referer:" + dl.curatedReferer]);
                  _oiqq.push(["oiq_addPageCat", "genre:" + dl.genre]);
                  _oiqq.push(["oiq_addPageCat", "tags:" + dl.tags]);
                  _oiqq.push(["oiq_addPageCat", "categories:" + dl.categories]);
                  _oiqq.push(["oiq_doTag"]);
                  _oiqq.push(["oiq_addPageLifecycle", "ecv3"]);
                }
                var oiq = document.createElement("script"); oiq.type = "text/javascript"; oiq.async = true;
                oiq.src = document.location.protocol + "//px.owneriq.net/stas/s/0frxgz.js";
                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(oiq, s);
              },
              callback =  (tcData, success) => {
                if(success && tcData.eventStatus === 'tcloaded') {
                  if( !tcData.gdprApplies || ( tcData.gdprApplies && tcData.tcString ) ){
                    addOipScript();
                  }
                  __tcfapi('removeEventListener', 2, (success) => {}, tcData.listenerId );
                }
              };
            __tcfapi( "addEventListener", 2, callback );
          })(window, window.dataLayer);
        });
      </script>
          
          
          
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("//action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=BrooklynVegan&ncv=24");
      });</script>
          
          
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6665296" });
        (function() {
          var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
          el.parentNode.insertBefore(s, el);
        })();
      });</script>
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <script type="text/javascript" src="//dfm7wh2x5l4za.cloudfront.net/script.js"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=www.brooklynvegan.com&v=faac599aae36a1b9701b044d93ab8f550b9cf1a3&mver=122"></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '631470830669776');
    fbq('track', 'PageView');</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "www.brooklynvegan.com";ZERG.user = 751;</script>
          <script type="application/ld+json">{"@context":"https://schema.org","@type":"article","headline":"Bandcamp exclusives for today’s fundraiser (Sonic Youth, Death Cab, Swervedriver, Merge comp, more)","publisher":{"@type":"Organization","name":"Brooklyn Vegan","logo":{"@type":"ImageObject","url":"//townsquare.media/site/838/files/2015/12/bv-1logo-new1.png"}},"url":"https://www.brooklynvegan.com/bandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.brooklynvegan.com/bandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more/"},"description":"Plus: Swervedriver, The Mountain Goats, Lingua Ignota, Lucy Dacus, Charly Bliss, Wylde Ratttz (Sonic Youth, Stooges, Minutemen), Petrol Girls, Fleet Foxes, Lakes (Glassjaw cover), and more.","image":"//townsquare.media/site/838/files/2020/12/sonic-youth-live-in-copenhagen.jpg","author":"BrooklynVegan Staff","keywords":"brooklynvegan bandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more music ajj anjimile b-52s bandcamp best-ex bill-mackay camp-blood cat-power charly-bliss chris-farren cinema-stare cliffdiver cloaker community-records corrupt-vision dan-potthast death-cab-for-cutie dominic-minix fleet-foxes fruit-bats geoff-rickly gilt glassjaw godthrymm hard-girls hate-club hinder hiss-golden-messenger hornbill illuminati-hotties indigo-girls into-it-over-it jaime-brooks jeff-rosenstock jersey-interchange johanna-warren josh-homme karl-blau ken-vandermark lakes lala-lala laughingstock lingua-ignota lucy-dacus macseal michael-malarkey mike-hugenor mount-eerie nathan-salsburg nessa nnamdi no-better oceantor odd-robot ogikubo-station ohmme otis-redding p-s-youredead palette-knife pet-symmetry petrol-girls pink-navel pom-pom-squad post-animal pronoun pylon queen-of-jeans radical-dads ramonda-hammer ratboys rem riverby rosie-tucker routine sad13 sarah-and-the-safe-word sean-bonnette sidney-gish sonic-youth spectral-voice superchunk swervedriver the-casket-lottery the-mountain-goats the-weekend-run-club this-white-light titus-andronicus to-be-gentle torres two-minutes-to-late-night will-butler wye-oak you-me-and-everyone-we-know zola-jesus pagetype-post indie-alternative web","datePublished":"2020-12-04T14:16:20.000Z","dateCreated":"2020-12-04T14:16:20.000Z","dateModified":"2020-12-04T18:47:42.000Z"}</script>
        </head>
        <body>
          <div id="fb-root"></div>
          <div id="app"><div><div id="site-menu-wrapper" class="no-showticker"><div class="site-menu-drawer"><ul class="promo-links"><li><span>Trending:</span></li><li><a title="Tour Updates" href="https://brooklynvegan.com/tags/coronavirus?from=trending">Tour Updates</a></li><li><a title="Livestreams" href="https://brooklynvegan.com/tags/livestream?from=trending">Livestreams</a></li><li><a title="New Songs" href="/tags/new-songs/?from=trending">New Songs</a></li><li><a title="Contests" href="/category/contests/">Contests</a></li><li><a title="Best of 2020" href="/tags/best-of-2020/?from=trending">Best of 2020</a></li></ul></div><div id="site-menu-bg"></div><div class="next-to-logo"><div class="non-menu-content"><a class="logo" href="/" itemProp="logo url" alt="BrooklynVegan" title="BrooklynVegan" data-source="logo"><img src="//townsquare.media/site/838/files/2017/10/bv-1logo-new1.png" alt="BrooklynVegan" title="BrooklynVegan"/></a><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow"><div class="wrapper"><ul class="links"><li class="hassub"><a href="/" title="Home" data-source="nav">Home</a></li><li class="hassub"><a href="/category/music/" title="Music" data-source="nav">Music</a></li><li class="hassub"><a href="/category/metal/" title="Metal" data-source="nav">Metal</a><ul class="links submenu"><li class="hassub"><a href="/category/metal/" title="BV Metal News" data-source="nav">BV Metal News</a></li><li class="hassub"><a href="http://invisibleoranges.com" title="Invisible Oranges" data-source="nav" target="_blank">Invisible Oranges</a></li><li class="hassub"><a href="http://www.invisibleoranges.com/metal-show-listings/" title="Metal Show Calendars" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub"><a href="/category/hiphop/" title="Rap" data-source="nav">Rap</a></li><li class="hassub"><a href="/category/dance/" title="Dance" data-source="nav">Dance</a></li><li class="hassub"><a href="/category/comedy/" title="Comedy" data-source="nav">Comedy</a><ul class="links submenu"><li class="hassub"><a href="/category/comedy/" title="Comedy News" data-source="nav">Comedy News</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/events/comedy" title="NYC Comedy Calendar" data-source="nav" target="_blank">NYC Comedy Calendar</a></li></ul></li><li class="hassub"><a href="/category/tv/" title="TV" data-source="nav">TV</a></li><li class="hassub"><a href="/category/movies/" title="Movies" data-source="nav">Movies</a></li><li class="hassub"><a href="/category/tour-dates/" title="Tours" data-source="nav">Tours</a></li><li class="hassub"><a href="/category/to-do/" title="Listings" data-source="nav">Listings</a><ul class="links submenu"><li class="hassub"><a href="/category/to-do/" title="What&#x27;s Going On (NYC)" data-source="nav">What&#x27;s Going On (NYC)</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/brooklynveganpresents" title="BV Presents Events" data-source="nav" target="_blank">BV Presents Events</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com" title="NYC Show Calendar" data-source="nav" target="_blank">NYC Show Calendar</a></li><li class="hassub"><a href="http://chicago-shows.brooklynvegan.com" title="Chicago Show Calendar" data-source="nav" target="_blank">Chicago Show Calendar</a></li><li class="hassub"><a href="http://austin-shows.brooklynvegan.com" title="Austin Show Calendar" data-source="nav" target="_blank">Austin Show Calendar</a></li><li class="hassub"><a href="http://www.invisibleoranges.com/metal-show-listings/" title="Metal Show Calendars" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub"><a href="/contact-us" title="Contact" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/contact-us" title="Contact Us" data-source="nav">Contact Us</a></li><li class="hassub"><a href="/about-us" title="About Us" data-source="nav">About Us</a></li><li class="hassub"><a href="/newsletter-sign-up" title="Newsletter Sign-up" data-source="nav">Newsletter Sign-up</a></li></ul></li><li class="hidden-menu hassub hide"><a class="more-icon" href="#">More</a><ul class="links submenu"><li class="hassub hide"><a href="/" title="Home" data-source="nav">Home</a></li><li class="hassub hide"><a href="/category/music/" title="Music" data-source="nav">Music</a></li><li class="hassub hide"><a href="/category/metal/" title="Metal" data-source="nav">Metal</a><ul class="links submenu"><li class="hassub"><a href="/category/metal/" title="BV Metal News" data-source="nav">BV Metal News</a></li><li class="hassub"><a href="http://invisibleoranges.com" title="Invisible Oranges" data-source="nav" target="_blank">Invisible Oranges</a></li><li class="hassub"><a href="http://www.invisibleoranges.com/metal-show-listings/" title="Metal Show Calendars" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub hide"><a href="/category/hiphop/" title="Rap" data-source="nav">Rap</a></li><li class="hassub hide"><a href="/category/dance/" title="Dance" data-source="nav">Dance</a></li><li class="hassub hide"><a href="/category/comedy/" title="Comedy" data-source="nav">Comedy</a><ul class="links submenu"><li class="hassub"><a href="/category/comedy/" title="Comedy News" data-source="nav">Comedy News</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/events/comedy" title="NYC Comedy Calendar" data-source="nav" target="_blank">NYC Comedy Calendar</a></li></ul></li><li class="hassub hide"><a href="/category/tv/" title="TV" data-source="nav">TV</a></li><li class="hassub hide"><a href="/category/movies/" title="Movies" data-source="nav">Movies</a></li><li class="hassub hide"><a href="/category/tour-dates/" title="Tours" data-source="nav">Tours</a></li><li class="hassub hide"><a href="/category/to-do/" title="Listings" data-source="nav">Listings</a><ul class="links submenu"><li class="hassub"><a href="/category/to-do/" title="What&#x27;s Going On (NYC)" data-source="nav">What&#x27;s Going On (NYC)</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/brooklynveganpresents" title="BV Presents Events" data-source="nav" target="_blank">BV Presents Events</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com" title="NYC Show Calendar" data-source="nav" target="_blank">NYC Show Calendar</a></li><li class="hassub"><a href="http://chicago-shows.brooklynvegan.com" title="Chicago Show Calendar" data-source="nav" target="_blank">Chicago Show Calendar</a></li><li class="hassub"><a href="http://austin-shows.brooklynvegan.com" title="Austin Show Calendar" data-source="nav" target="_blank">Austin Show Calendar</a></li><li class="hassub"><a href="http://www.invisibleoranges.com/metal-show-listings/" title="Metal Show Calendars" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub hide"><a href="/contact-us" title="Contact" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/contact-us" title="Contact Us" data-source="nav">Contact Us</a></li><li class="hassub"><a href="/about-us" title="About Us" data-source="nav">About Us</a></li><li class="hassub"><a href="/newsletter-sign-up" title="Newsletter Sign-up" data-source="nav">Newsletter Sign-up</a></li></ul></li></ul></li></ul><div class="site-menu-right"><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/brooklynvegan" target="_blank" data-social="youtube"><span class="icon-base icon-youtube"></span></a></li><li class="social"><a class="share-link facebook" href="http://www.facebook.com/BrooklynVegan" target="_blank" data-social="facebook"><span class="icon-base icon-facebook"></span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/brooklynvegan" target="_blank" data-social="twitter"><span class="icon-base icon-twitter"></span></a></li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/BrooklynVegan" target="_blank">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><div class="main-content"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-518796" data-location="/bandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-518796"><div class="content-header-header"><div class="react-parallax "><div class="react-parallax-background-children" data-bottom-top="transform:translate3d(0,-20%,0);" data-top-bottom="transform:translate3d(0,20%,0);"><figure class="frameme img-tag frame-loaded"><div class="theframe" data-image="https://townsquare.media/site/838/files/2020/12/sonic-youth-live-in-copenhagen.jpg" rel="" title="" style="background-image:url(&quot;https://townsquare.media/site/838/files/2020/12/sonic-youth-live-in-copenhagen.jpg?w=980&amp;q=75&quot;)"></div></figure></div><div class="react-parallax-content"><figure class="frameme img-tag"><div class="theframe" data-image="https://townsquare.media/site/838/files/2020/12/sonic-youth-live-in-copenhagen.jpg" rel="" title=""></div></figure></div></div><div class="header"><section class="title "><h1 class="">Bandcamp exclusives for today’s fundraiser (Sonic Youth, Death Cab, Swervedriver, Merge comp, more)</h1></section><div class="byline"><div class="authors"><address class="author"><div class="author-image icon-user"><figure class="frameme"><a class="theframe" data-image="//townsquare.media/wp-content/uploads/2012/10/profile.png" href="//www.brooklynvegan.com/author/brooklynvegan/" rel="author" title="BrooklynVegan Staff"></a></figure></div><a class="author-name" href="//www.brooklynvegan.com/author/brooklynvegan/" rel="author" title="BrooklynVegan Staff">BrooklynVegan Staff</a></address></div><time dateTime="2020-12-04 14:16:20 +0000">Published: December 4, 2020</time></div></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.brooklynvegan.com%2Fbandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more%2F%3Ftrackback%3Dfbshare_mobile" title="SHARE" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">SHARE</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Bandcamp%20exclusives%20for%20today%E2%80%99s%20fundraiser%20%28Sonic%20Youth%2C%20Death%20Cab%2C%20Swervedriver%2C%20Merge%20comp%2C%20more%29%20http%3A%2F%2Fwww.brooklynvegan.com%2Fbandcamp-exclusives-for-todays-fundraiser-sonic-youth-death-cab-swervedriver-merge-comp-more%2F%3Ftrackback%3Dtwitter_mobile%20%40brooklynvegan" title="TWEET" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">TWEET</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p>Since March, Bandcamp has been&#xA0;<a href="https://www.brooklynvegan.com/bandcamp-to-waive-its-cut-of-profits-on-first-fridays-of-may-june-july/">waiving their cut of sales</a>&#xA0;on the first Friday of every month for 24 hours (midnight to midnight Pacific), to support artists who have been impacted by the pandemic. So far, fans have purchased over $75 million worth of music and merch on&#xA0;<a href="https://www.brooklynvegan.com/monthly-bandcamp-friday-artist-fundraisers-will-continue-through-2020/">Bandcamp Fridays</a>, directly benefiting artists and labels. As the pandemic is &quot;far from over,&quot; they&apos;ll continue to hold the fundraisers&#xA0;<a href="https://www.brooklynvegan.com/monthly-bandcamp-friday-artist-fundraisers-will-continue-through-2020/">through the&#xA0;end of the year</a>, and today (12/4) is the final one.</p><p>Like on&#xA0;<a href="https://www.brooklynvegan.com/bandcamp-exclusives-for-todays-fundraiser-denzel-curry-big-thief-kimya-dawson-more/">previous Bandcamp days</a>, some artists have special releases coming out today, which we&apos;ve listed below. You can also, of course, buy&#xA0;<a href="https://www.brooklynvegan.com/category/music/new-releases/">new releases</a>, or&#xA0;<a href="https://www.brooklynvegan.com/10-great-albums-we-recommend-buying-on-bandcamp-today/">older albums</a>&#xA0;you hadn&apos;t gotten around to getting yet.</p><div class="in-article-oop-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><p><strong>SONIC YOUTH - <em>LIVE IN COPENHAGEN 2000</em></strong></p><p>Sonic Youth have unearthed more rarities from their archives, including this Y2K era live show. From the liner note written by WFMU&apos;s Brian Turner: &quot;A good snapshot into the Sonics&apos; live state of mind circa 2000 in the form of a sprawling, and often exploratory set of some standards and five tracks from their recently-released <em>NYC Ghosts &amp; Flowers</em>.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2250902252/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>WYLDE RATTTZ (SONIC YOUTH/STOOGES/MIKE WATT/SEAN ONO LENNON) - <em>SHED/SACK/PLUG</em></strong></p><p><strong>The Wylde Ratz</strong>, aka the <a href="https://www.brooklynvegan.com/tags/wylde-ratttz/">supergroup</a> of&#xA0;<strong>Ron Asheton</strong> (<strong>Stooges</strong>), <strong>Sean Ono Lennon</strong>,&#xA0;<strong>Sonic Youth</strong>&apos;s <strong>Thurston Moore</strong>&#xA0;and <strong>Steve Shelley</strong>, and <strong>Mike Watt</strong> (Minutemen, fIREHOSE) who formed to record covers for Todd Haynes&apos; 1998 film <em>Velvet Goldmine</em>, also recorded &quot;an epic late night of improvised instrumental space jams during their 1997 album sessions.&quot; (Mark Arm of Mudhoney, who appears on some Ratttz tracks, is not on this recording.) <em>SHED/SACK/PLUG</em>&#xA0;is the fourth and final of a series of singles and EPs of those recordings (produced by Don Fleming for Instant Mayhem Productions).</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2567312252/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>SWERVEDRIVER - <i>HONEY HEAVENS ABOVE</i></b></p><p>Veteran shoegaze greats Swervedriver have released a new compilation featuring remastered b-sides from the <i>Raise</i> era.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2801500377/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>THIS WHITE LIGHT - <i>JOSH HOMME&#x200B;/&#x200B;PINK DUCK SESSIONS</i></b></p><p>Two years ago, Greg Anderson (co-founder of Southern Lord Records and member of Goatsnake, Sunn O))), and more), Bryan Herweg (of Pelican), Jade Devitt (who played in Engine Kid with Greg Anderson), and vocalist Jen Wood (of &apos;90s Kill Rock Stars band Tattle Tale, The Postal Service&apos;s &quot;Nothing Better,&quot; her solo career, and more) formed <a href="https://www.brooklynvegan.com/this-white-light-jen-wood-mems-of-goatsnake-sunn-o-pelican-listen/">This White Light</a>. Unfortunately, the band ended up being short-lived, but they made one more two-song recording (produced by Josh Homme) before breaking up, and here it is.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2932167834/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>TWO MINUTES TO LATE NIGHT - COVERS VOL. 6</b></p><p>Two Minutes to Late Night have been doing awesome quarantine covers videos all year, and they&apos;ve been releasing EPs of the covers on Bandcamp days. This is their sixth, and as always, it&apos;s only available for 24 hours.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2057174317/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>MIKE HUGUENOR - LIVE EP (FT. JEFF ROSENSTOCK, HARD GIRLS MEMBERS)</strong></p><p><strong>Mike Huguenor</strong> (Hard Girls, Jeff Rosenstock&apos;s band, etc) has released a brand new EP titled <em>&amp; the Uncanny X&apos;ed Men [Live]</em>. It takes recordings from his recent full-band livestream session, which featured a five-guitarist band (including <strong>Jeff Rosenstock</strong>, <strong>Hard Girls</strong>&apos; Morgan Herrell, Jeff Rosenstock drummer Kevin Higuchi, and more).</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=955083491/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>JEFF ROSENSTOCK, DAN POTTHAST, OGIKUBO STATION, more - <em>COMP FOR A CAUSE</em></strong></p><p>Speaking of Jeff Rosenstock, he&apos;s also on this benefit comp that came out earlier this week, <a href="https://www.brooklynvegan.com/jeff-rosenstock-ogikubo-station-dan-potthast-more-contribute-new-songs-to-benefit-comp/"><em>Comp for a Cause</em></a>, alongside <strong>Dan Potthast</strong>, <strong>Ogikubo Station</strong>, <strong>AJJ</strong>&apos;s <strong>Sean Bonnette</strong>, <strong>Diners</strong>, <strong>Karl Blau</strong>.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=3893781981/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; width=\&quot;300\&quot; height=\&quot;150\&quot; style=\&quot;border: 0; width: 100%; height: 120px;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>DEATH CAB FOR CUTIE - <em>THE GEORGIA EP</em></strong></p><p>In celebration of Georgia turning blue this past election (for the first time since 1992), <strong>Death Cab For Cutie </strong>released a collection of covers, with proceeds benefiting the state&apos;s <a href="https://www.brooklynvegan.com/stacey-abrams-discusses-how-you-can-help-in-the-georgia-senate-race-its-about-saving-democracy/">upcoming runoff Senate election</a> (via <strong>Stacey Abrams</strong>&apos; <a href="https://fairfight.com/">Fair Fight</a> initiative). <a href="https://www.brooklynvegan.com/death-cab-for-cutie-covering-rem-nmh-more-for-georgia-senate-benefit-ep/"><em>The Georgia EP</em></a>, which is only available for the next 24-hours, includes covers of songs by <strong>R.E.M.</strong>, <strong>TLC</strong>, <strong>Cat Power</strong>, <strong>Neutral Milk Hotel</strong>, and others.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2292468963/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>MERGE RECORDS (TITUS ANDRONICUS, FRUIT BATS, WYE OAK, WILL BUTLER, TORRES, SUPERCHUNK, and more) - <em>GOING TO GEORGIA</em> EP</strong></p><p>In another effort to help flip Georgia completely blue, Merge Records has unveiled a massive compilation called <em>Going to Georgia</em>, featuring a huge number of Merge artists covering Georgia artists and Georgia-themed songs. Says Merge founder and Superchunk leader Mac McCaughan, &quot;We live in North Carolina, where a racist Republican legislature has worked for a generation to undermine democracy through unprecedented voter suppression. Our neighbors in Georgia have successfully fought back, through the efforts of Fair Fight and other organizations. The voters who turned Georgia blue in November can now elect Raphael Warnock and Jon Ossoff, take back power in the Senate, and make true progress possible in this country. The Merge artists on this comp came together quickly, recording in various quarantine situations, to pay tribute to their favorite artists from Georgia, or maybe just record their favorite songs with &#x201C;Georgia&#x201D; in the title, and to support those working hard in Georgia to make sure everyone&#x2019;s voice is heard.&quot; Some of the covers on this comp: </p><p><strong>Will Butler</strong> - &quot;Electrolite&quot; [<strong>R.E.M</strong>]<br><strong>TORRES</strong> - &quot;Topaz&quot; [<strong>The B-52&apos;s</strong>]<br><strong>Fruit Bats</strong> - &quot;I&apos;ve Been Loving You Too Long&quot; [<strong>Otis Redding</strong>]<br><strong>Wye Oak</strong> - &quot;Crazy&quot; [<strong>Pylon</strong>]<br><strong>Hiss Golden Messenger</strong> - &quot;The Greatest&quot; [<strong>Cat Power</strong>]<br><strong>Titus Andronicus</strong> - &quot;Closer to Fine&quot; [<strong>Indigo Girls</strong>]</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=496830267/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>THE MOUNTAIN GOATS - <em>THE JORDAN LAKE SESSIONS</em></strong></p><p><strong>The Mountain Goats</strong> have just unveiled a collection of live recordings from around the release of <em>Getting Into Knives</em>, entitled <em>The Jordan Lake Sessions</em>.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=196992671/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>LINGUA IGNOTA - <i>THE CALIGULA DEMOS</i></b></p><p>Lingua Ignota has released an album of demos from her great 2019 album <i>Caligula</i>. &quot;You&#x2019;ll hear the record coming together, motifs from one song in another, things that were heavy done quietly, some things that never made it, lyrics moving around,&quot; she says. </p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=4127990397/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>CHARLY BLISS - &quot;MARBLE&quot; (DEMO)</b></p><p>&quot;An amazing part about being in a touring band is the opportunity to meet so many wonderful people all over the world,&quot; Charly Bliss write. &quot;One of the brightest and kindest individuals we have met along the way has been Marcy, or as you might know her, the CEO and cofounder of CB potato!! Marcy has recently decided to undergo gender confirmation surgery. In an effort to help her raise funds to afford the surgery, we will be releasing a favorite b-side of our&#x2019;s, &#x201C;Marble&#x201D;, on Bandcamp this Friday, 12/4. All of the proceeds will go directly to Marcy. This one is very close to our hearts so please consider pitching in! We love you all!!!&quot; Purchase at <a href="https://charlybliss.bandcamp.com/track/marble-demo">Bandcamp</a>.</p><p><strong>PETROL GIRLS - &quot;I BELIEVE THEM&quot;</strong></p><p><strong>Petrol Girls</strong> have released a new Bandcamp-exclusive single (and video) &quot;I Believe Them,&quot; with proceeds benefiting <a href="https://twitter.com/solnotsilence">Solidarity Not Silence</a>, the campaign kickstarted by Ren Aldridge (of Petrol Girls) and Nadia Javed (of <strong>The Tuts</strong>). They write:</p><blockquote><p>Petrol Girls are releasing this track to raise as much money as we possibly can for Solidarity Not Silence and to widen the network of people supporting the cause. Solidarity Not Silence is the legal defence fund for a group of women, including myself (Ren), who are being sued for defamation by a man in the music industry because of comments that we each made separately regarding his behaviour towards women.</p><p>We&#x2019;ve been fighting this case since December 2016 and desperately need help raising money for our legal costs. The only reason we&#x2019;ve been able to successfully fight this case as long as we have is because we were able to come together and fundraise for our legal defence. Help us keep our legal representation all the way to court and win this!!!</p><p>As one of the Solidarity Not Silence defendants, I&#x2019;m limited in what I can say about the case whilst it&#x2019;s ongoing. However, there&#x2019;s nothing to stop me contributing to a wider conversation about sexual violence and the law - which is what this track, &#x2018;I Believe Them (Solidarity Not Silence)&#x2019; is about.</p></blockquote><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;title&quot;:&quot;Petrol Girls - I Believe Them (Official Motion Picture)&quot;,&quot;author_name&quot;:&quot;HassleRecords&quot;,&quot;author_url&quot;:&quot;https://www.youtube.com/user/HassleRecords&quot;,&quot;type&quot;:&quot;video&quot;,&quot;height&quot;:270,&quot;width&quot;:480,&quot;version&quot;:&quot;1.0&quot;,&quot;provider_name&quot;:&quot;YouTube&quot;,&quot;provider_url&quot;:&quot;https://www.youtube.com/&quot;,&quot;thumbnail_height&quot;:360,&quot;thumbnail_width&quot;:480,&quot;thumbnail_url&quot;:&quot;https://i.ytimg.com/vi/V6sGaCpnReE/hqdefault.jpg&quot;,&quot;html&quot;:&quot;&lt;iframe width=\&quot;480\&quot; height=\&quot;270\&quot; src=\&quot;https://www.youtube.com/embed/V6sGaCpnReE?feature=oembed\&quot; frameborder=\&quot;0\&quot; allow=\&quot;accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\&quot; allowfullscreen&gt;&lt;/iframe&gt;&quot;}"></div><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/track=3043410264/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>FLEET FOXES - <em>SHORE</em> STEMS</strong></p><p><strong>Fleet Foxes</strong> have released the stems from this year&apos;s <em>Shore</em>. &quot;VERY excited to release all of the stems for Shore this Friday on Bandcamp,&quot; says Robin Pecknold. &quot;This is eleven hours of all of the album&apos;s isolated tracks, solo&apos;d drums, vocals, horns, bass, guitars - every individual piece of every song untangled and laid bare. These aren&apos;t royalty free, but any and all remixing / sampling / twisting / creative reuse and reimagining for your personal, non-commercial use is highly encouraged. And if you want to sample for commercial release, just get in touch. Enjoy!&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2107253024/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>ZOLA JESUS - &quot;KRUNK&quot; (ARMENIAN FOLK SONG COVER)</b></p><p>Zola Jesus has covered the Armenian folk song &quot;Krunk&quot; as a Bandcamp exclusive to raise money for the <a href="https://www.armeniafund.org/">Armenia Fund</a>. &quot;I first heard the song &#x2018;Krunk&#x2019; (Crane) while listening to a collection of songs sung by Lousine Zakarian, a renowned Armenian soprano,&quot; she said. &quot;Her recording was so devastatingly beautiful, it spoke to me on many levels. The song evoked so much yearning and sadness, yet at the same time it felt so delicate, like her voice could lift off and fly away. It felt like the purest expression of the ineffable Armenian Soul. I never thought I&#x2019;d be able to do the song justice, and I still don&#x2019;t, but the song is so meaningful to me that performing it became a compulsion. Once I heard about the crisis happening in Artsakh, my heart really pained for the Armenian people. They have survived genocides, wars, battles for autonomy and independence, and now this &#x2014; fighting to reclaim a sacred place that represents so much of their ancient heritage and resilience. I wanted to honor and pay my support to the Armenian Soul, and to acknowledge all the lives tragically lost this year in the war with Azerbaijan. Proceeds of this song will go to the Armenian Fund, to help support the needs of civilians on the ground in Nagorno-Karabakh (Artsakh.)&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/track=162594773/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>AJJ - &quot;HORSEHAIR VASE&quot; &amp; &quot;YOU SWAN, GO ON&quot; (MOUNT EERIE COVER)</b></p><p>AJJ have released a Bandcamp-exclusive two-song single with the new song &quot;Horsehair Vase&quot; and a stunning cover of Mount Eerie&apos;s &quot;You Swan, Go On.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=163552777/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>CHAD VANGAALEN - <i>NTH</i></b></p><p>Chad VanGaalen has released <i>NTH</i>, &quot;a new collection of off-gassing instrumentals, exclusive to Bandcamp. When preparing this collection, I was thinking of people needing less talking and more peaceful vibrations, so I hope this helps mellow the mood.&quot; All profits will go to the Calgary Women&apos;s Emergency Shelter.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=1947027054/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>THE CASKET LOTTERY - &quot;ANOTHER HOLIDAY&quot;</b></p><p>The Casket Lottery recently released a new album, and now they released this non-album track as a Bandcamp exclusive as the holiday season approaches. &quot;Recorded during the same session as Short Songs For End Times. Another Holiday didn&apos;t seem like it fit the record but it feels like an accurate recap for the 2020 holiday season,&quot; they write.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/track=2717036741/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>JERSEY INTERCHANGE - STOLEN IDEAS EP</strong></p><p><strong>Jersey Interchange</strong>, the <a href="https://www.brooklynvegan.com/chris-gethard-mikey-erg-mems-of-folly-catch-22-midtown-more-tapped-for-nj-punk-covers-project/">quarantine project</a> created by NJ&apos;s Christian Lesperance featuring over 50 musicians from NJ&apos;s long-running punk scene covering (mostly) NJ punk songs, has collected some of the recordings from the project for this EP, including cover of songs by <strong>The Misfits</strong>, <strong>The Gaslight Anthem</strong>, and others). <em>Stolen Ideas</em> is set to benefit the Jersey organization, <a href="http://www.theelizabethcoalition.org">The Elizabeth Coalition To House the Homeless</a>, a group that advocates for the rights of homeless.</p><p>&quot;When I started the Jersey Interchange project, the goal was to just have fun playing music with friends while we were all stuck at home,&quot; says Lesperance. &quot;It quickly turned into something that a wide audience of people were enjoying, and now we have the chance to use the project as a way to raise some funds for a great organization that means a lot to me and my family. My mother has been heavily-involved with the Elizabeth Coalition since I was a pre-teen, and made sure that her family also got involved with volunteering and supporting the organization. We all donated our time to helping at their soup kitchens, clothing drives and other events as we grew up understanding the privileges we held in comparison to some, who didn&#x2019;t know where they would house or feed their families for the foreseeable future. Homelessness is not something we can sweep under the rug anymore. It&#x2019;s in our face, every day, and it&#x2019;s screaming for us to come together and eradicate it.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=472709731/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>SPECTRAL VOICE - <i>NECROTIC DEMOS</i></b></p><p>Via Dark Descent: &quot;For the first time, all official non-album material is finally available in one place, in dedication towards all cultists and gloomy fanatics who have supported THE SPECTRAL VOICE since the early years of these recordings. The self-released LP &#x201C;Necrotic Demos&#x201D; contains the original &#x201C;Necrotic Doom&#x201D; demo and all tracks from the out-of-print split EPs. Dark Descent Records present the Compact Disc edition as a digipak with bonus track.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=1556560752/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>JAIME BROOKS - <i>MAIN POP GIRLS 2015&#x200B;-&#x200B;2018 (THE DEMOS)</i></b></p><p>Jaime Brooks (Elite Gymnastics, Default Genders) has released a compilation of demos of songs that ended up on the album <i>main pop girl 2019</i>. &quot;a lot of these were posted on my soundcloud in kind of a low key way during that time period and lots of people who developed attachments to these versions have asked me to post them, so here they are, for the last bandcamp friday of 2020,&quot; Jaime says.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=173261315/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>CORRUPT VISION / AGATHOCLES SPLIT</b></p><p>OC ska-core ragers Corrupt Vision have released their side of a split with Agathocles to Bandcamp, featuring three raw, gritty songs including a cover of Spazz&apos;s <a href="https://www.brooklynvegan.com/we-reviewed-all-101-songs-on-short-music-for-short-people-for-its-21st-bday-because-quarantine/"><i>Short Music For Short People</i></a> classic &quot;A Prayer For The Complete &amp; Utter Eradication Of All Generic Pop-Punk&quot; (retitled as &quot;A Prayer For The Complete &amp; Utter Eradication Of All Generic Ska-Punk&quot;).</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=1373618432/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>LAKES - GLASSJAW COVER </strong></p><p>UK band <strong>Lakes</strong> have released a glistening, atmospheric lo-fi pop cover of <strong>Glassjaw</strong>&apos;s <i>Worship and Tribute</i> classic &quot;Must&apos;ve Run All Day&quot; as a Bandcamp exclusive, and we&apos;re also premiering the song&apos;s video.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;title&quot;:&quot;Lakes – Must&#x27;ve Run All Day (Glassjaw Cover) [OFFICIAL MUSIC VIDEO]&quot;,&quot;author_name&quot;:&quot;Know Hope Records&quot;,&quot;author_url&quot;:&quot;https://www.youtube.com/channel/UCqS88d-_ecculZegXjjebQQ&quot;,&quot;type&quot;:&quot;video&quot;,&quot;height&quot;:270,&quot;width&quot;:480,&quot;version&quot;:&quot;1.0&quot;,&quot;provider_name&quot;:&quot;YouTube&quot;,&quot;provider_url&quot;:&quot;https://www.youtube.com/&quot;,&quot;thumbnail_height&quot;:360,&quot;thumbnail_width&quot;:480,&quot;thumbnail_url&quot;:&quot;https://i.ytimg.com/vi/pTuWupP0JKc/hqdefault.jpg&quot;,&quot;html&quot;:&quot;&lt;iframe width=\&quot;480\&quot; height=\&quot;270\&quot; src=\&quot;https://www.youtube.com/embed/pTuWupP0JKc?feature=oembed\&quot; frameborder=\&quot;0\&quot; allow=\&quot;accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\&quot; allowfullscreen&gt;&lt;/iframe&gt;&quot;}"></div><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/track=2931671963/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b><i>WORKS ON PROGRESS VOL. 1</i></b></p><p>Community Records, Strange Daisy Records, Defend New Orleans, and New Orleans Record Press have released the first two singles from <i>Works On Progress Vol. 1</i>, a compilation of BIPOC musicians that will benefit all the musicians involved. It came together with help from Dominic Minix (Bad Operation, Solange&apos;s touring band, etc), who contributes the song &quot;Try Again&quot; to the comp, and it also has music by LB and Cam Smith, Frewhun, Sexy Dex and The Fresh, AF The Naysayer, Christelle Bofale, Zetroc, Xavier Molina, Solomon Wexley, Primus Roman, Delores Galore, and Sly Watts.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=518240903/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p>--</p><p><b>TO BE GENTLE - <i>DISCOGRAPHY 2017-2020</i></b></p><p>Eugene, Oregon screamo greats To Be Gentle have released a 34-song discography compilation featuring &quot;singles, EP&apos;s, LP&apos;s, splits, live audio, and previously unreleased demos and rarities. Also featured is a remastered version of To Be Gentle&apos;s sophomore album, which was mastered by Jack Shirley at The Atomic Garden Studios.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=515720026/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>NNAMD&#xCF;, POST ANIMAL, INTO IT. OVER IT., RATBOYS, LALA LALA, and more - <em>WARM VIOLET: A COMPILATION FOR CHICAGO COMMUNITY JAIL SUPPORT</em></strong></p><p>A whole bunch of Chicago artists contributed songs to this 46-track benefit compilation, <a href="https://www.brooklynvegan.com/3-cool-indie-benefit-comps-announced-for-bandcamp-friday/"><em>Warm Violet</em></a>, with proceeds going toward <a href="https://www.instagram.com/chicommunityjailsupport/">Chicago Community Jail Support</a>, a mutual aid network supporting those recently released from Cook County Jail. Artists include NNAMDI &amp; Post Animal, OHMME, BIll MacKAy, Ken Vandermark, Lala Lala, Ratboys, Into It. Over It., Pet Symmetry, and many more.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2245640441/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; width=\&quot;300\&quot; height=\&quot;150\&quot; style=\&quot;border: 0; width: 100%; height: 120px;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>NO SLEEP RECORDS - <em>NO SLEEP TIL CHRISTMAS 8</em></strong></p><p><strong>No Sleep Records</strong> have a brand new benefit comp in the spirit of the holiday season, with proceeds being donated to Feeding America. Branded as &quot;16+ tracks of winter cheer, or something,&quot; the EP includes tracks from Best Ex, Cinema Stare, Cliffdiver, Cloaker, Thursday&apos;s Geoff Rickly (covering Tori Amos), GILT (covering Joyce Manor), Hate Club, Hornbill, Laughingstock, Michael Malarkey, No Better, Odd Robot, Palette Knife, p.s.you&apos;redead, Riverby, Sarah and the Safe Word, The Weekend Run Club, and more.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=1622105366/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>OCEANTOR, RAMONDA HAMMER, NESSA, more - <em>SING IT RIGHT BACK: SONGS OF ROSIE TUCKER</em></strong></p><p>This benefit compilation features 19 covers of songs by <strong>Rosie Tucker</strong> from artists such as <strong>Oceantor</strong>, <strong>Ramonda Hammer</strong>, <strong>Nessa</strong>, and a handful of others. <em>Sing It Right Back: Songs of Rosie Tucker</em>, was organized on Twitter, with proceeds going to <a href="https://latenantsunion.org/">Los Angeles Tenants Union</a>, &quot;an autonomous, member-funded union which fights for the human right to housing.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=3255747221/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; width=\&quot;300\&quot; height=\&quot;150\&quot; style=\&quot;border: 0; width: 100%; height: 120px;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>YOU, ME, AND EVERYONE WE KNOW - <em>ALIVE IN CHICAGO</em></strong></p><p><strong>You Me and Everyone We Know</strong> have released a brand new live album, <em>Alive in Chicago</em>, featuring recordings from their set at Reggies Rock Club in Chicago on February 12, 2017. &quot;This was meant to be the band&apos;s final performance and now it&apos;s available for you to hear wherever you are,&quot; the description reads.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=3441192218/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; width=\&quot;300\&quot; height=\&quot;150\&quot; style=\&quot;border: 0; width: 100%; height: 120px;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>ILLUMINATI HOTTIES, POM POM SQUAD, JOHANNA WARREN, SAD13, ROUTINE, and more - <em>SIMPLY HAVING A WONDERFUL COMPILATION</em></strong></p><p>Father/Daughter and Wax Nine Records are behind a brand new benefit compilation that was released today called <a href="https://www.brooklynvegan.com/3-cool-indie-benefit-comps-announced-for-bandcamp-friday/"><em>Simply Having a Wonderful Compilation</em></a>. The comp, created in support of Feeding America, includes &quot;yuletide recordings&quot; from artists such as <strong>Melkbelly</strong>, <strong>Pom Pom Squad</strong>, <strong>Routine</strong>, <strong>Illuminati Hotties</strong>, and a handful of others.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=822649340/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; width=\&quot;300\&quot; height=\&quot;150\&quot; style=\&quot;border: 0; width: 100%; height: 120px;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>ANJIMILE, SIDNEY GISH, CAMP BLOOD, PINK NAVEL, and more - <em>ECLECTIC CHANGE COMPILATION</em></strong></p><p>Boston area artists have contributed songs to this new benefit compilation, <a href="https://www.brooklynvegan.com/3-cool-indie-benefit-comps-announced-for-bandcamp-friday/"><em>The Eclectic Change Comp</em></a>, with proceeds benefiting <a href="https://www.nationalbailout.org/">National Bail Out</a> and <a href="https://www.transtrenderz.com/">TranzTrenderz</a>.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=1763638596/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>GODTHRYMM - &quot;THE VASTNESS SILENT&quot;</strong></p><p>UK death-doom band <strong>Godthrymm</strong> has returned with an exclusive new single, &quot;The Vastness Silent.&quot; The track is a b-side off their recent debut record, <em>Reflections</em>, that they didn&apos;t finish in time for the release, and it comes backed by an alternate version of &quot;We Are The Dead.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=3947496556/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>NATHAN SALSBURG - <em>LANDWERK NO. 2</em></strong></p><p><strong>Nathan Salsburg</strong> has released a new album of solo guitar recordings, <em>Landwerk No. 2</em>, which is a follow-up to <em>Landwerk</em> from earlier this year. &quot;In this case, [the fragments are pulled from] two klezmer sides, one Yiddish folk song, and one tune by a Slovak miners&apos; orchestra from Northeastern Pennsylvania, home of six generations of Salsburgs,&quot; says Nathan. &quot;While the first volume just happened to coincide with the first months of 2020&#x2019;s problematic peculiarity, No. 2 was undertaken in the depths of the late summer and early fall, when political/social/existential despair hung at their heaviest. These are musical attempts to translate the past into the present, or to redeem the present through the past, or to discover, in Michael L&#xF6;wy&apos;s formulation (in Chris Turner&apos;s translation), a &apos;critical constellation formed by a particular fragment of the past with a particular moment of the present.&apos;&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=3157495267/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>THE CO FOUNDER - NEW VERSIONS OF SONGS &quot;EATING ALONE,&quot; &quot;SOLO BEACH DAY&quot;</strong></p><p>PacNW emo band <strong>The Co Founder</strong> are back from a year-long hiatus and just released some reworked versions of two older songs (&quot;Eating Alone&quot; and &quot;Solo Beach Day&quot;) to raise money for Stacey Abrams&apos; <a href="https://fairfight.com/">Fair Fight</a>.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2085120161/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>LUCY DACUS - &quot;LIPS OF AN ANGEL&quot; (HINDER COVER)</strong></p><p>Lucy Dacus covered this mid-2000s Hinder song a few months ago, and is sharing it to Bandcamp now to raise money for <a href="https://www.theokraproject.com/">The Okra Project</a>.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/track=3513221419/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>RADICAL DADS - <em>RADICAL DADS EP (2009 DEMOS)</em></strong></p><p>Indie rock trio Radical Dads, which features former Clap Your Hands Say Yeah member Robbie Guertin, have this for Bandcamp Friday. &#x201C;New old free EP: We&apos;re giving away a 3-song EP of demos for songs from our first record! We recorded it in 2009, and until today it was available only via the avant-garde format of CD-R. So it&apos;s old and new at the same time. Enjoy!&#x201D;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2542715672/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; width=\&quot;300\&quot; height=\&quot;150\&quot; style=\&quot;border: 0; width: 100%; height: 120px;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>NO JOY - &quot;DISCO 6&quot; (<em>MOTHERHOOD</em> DEMOS)</strong></p><p>Montreal shoegazers No Joy are sharing a song that didn&apos;t make it onto their 2020 album <em><a href="https://www.brooklynvegan.com/album-reviews-guided-by-voices-no-joy-jonathan-richman-the-fall-dent-may-barringtone-clor/">Motherhood</a></em> for Bandcamp Day. Jasamine White-Gluz says she wrote &quot;Disco 6&quot; in March of 2016 and &quot;continued to work on it throughout our summer European 2016 tour with Jorge Elbrecht, who was playing guitar at the time. I kept revisiting it and trying to find its place but it never seemed to click. One potential collaborator I brought this song to once referred to it as &apos;sounding like when you walk into a Guitar Center and every instrument is playing at once&apos; I still love this track in all its confusing glory and hope you do too.&quot;</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/track=648715060/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><strong>RATBOYS, MACSEAL, PRONOUN, QUEEN OF JEANS, CHRIS FARREN, ANJIMILE, and more - <em>TV TUNES: A RETROSPECTIVE OF TV THEME SONGS</em></strong></p><p>Proceeds from this collection of covers of the theme songs of <em>The Sopranos, Adventure Time, Family Matters, Golden Girls, Degrassi, Jeopardy, Scooby Doo, Boy Meets World, Clueless, The L Word, Great British Bake Off, Gilmore Girls, Pokemon, Friends, Cheers, Arthur</em> and other TV shows go to <a href="https://www.firstnations.org/">First Nations Development Institute</a>.</p><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe style=\&quot;border: 0; width: 100%; height: 120px;\&quot; src=\&quot;https://bandcamp.com/EmbeddedPlayer/album=2019471739/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/\&quot; seamless wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p><b>SEE ALSO:</b></p><p>* 35&#xA0;<b>independent hip hop releases of 2020</b>&#xA0;we&#xA0;<a href="https://www.brooklynvegan.com/17-independent-hip-hop-releases-of-2020-we-recommend-buying-on-bandcamp-today/">recommend buying on Bandcamp</a></p><p>*&#xA0;<b>metal albums from 2020</b>&#xA0;we&#xA0;<a href="https://www.brooklynvegan.com/10-more-metal-albums-from-2020-we-recommend-buying-on-bandcamp-today/">recommend buying on Bandcamp</a>.</p><p>--</p><p>Browse the&#xA0;<a href="https://www.brooklynvegan.com/tags/bandcamp/">Bandcamp tag</a>&#xA0;for more.</p></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper"><span>Filed Under<!-- -->: </span><span><a href="//www.brooklynvegan.com/tags/ajj/">AJJ</a></span><span>, <a href="//www.brooklynvegan.com/tags/anjimile/">Anjimile</a></span><span>, <a href="//www.brooklynvegan.com/tags/b-52s/">B-52s</a></span><span>, <a href="//www.brooklynvegan.com/tags/bandcamp/">Bandcamp</a></span><span>, <a href="//www.brooklynvegan.com/tags/best-ex/">Best Ex</a></span><span>, <a href="//www.brooklynvegan.com/tags/bill-mackay/">Bill Mackay</a></span><span>, <a href="//www.brooklynvegan.com/tags/camp-blood/">Camp Blood</a></span><span>, <a href="//www.brooklynvegan.com/tags/cat-power/">Cat Power</a></span><span>, <a href="//www.brooklynvegan.com/tags/charly-bliss/">Charly Bliss</a></span><span>, <a href="//www.brooklynvegan.com/tags/chris-farren/">Chris Farren</a></span><span>, <a href="//www.brooklynvegan.com/tags/cinema-stare/">Cinema Stare</a></span><span>, <a href="//www.brooklynvegan.com/tags/cliffdiver/">Cliffdiver</a></span><span>, <a href="//www.brooklynvegan.com/tags/cloaker/">CLOAKER</a></span><span>, <a href="//www.brooklynvegan.com/tags/community-records/">community records</a></span><span>, <a href="//www.brooklynvegan.com/tags/corrupt-vision/">Corrupt Vision</a></span><span>, <a href="//www.brooklynvegan.com/tags/dan-potthast/">Dan Potthast</a></span><span>, <a href="//www.brooklynvegan.com/tags/death-cab-for-cutie/">Death Cab For Cutie</a></span><span>, <a href="//www.brooklynvegan.com/tags/dominic-minix/">Dominic Minix</a></span><span>, <a href="//www.brooklynvegan.com/tags/fleet-foxes/">Fleet Foxes</a></span><span>, <a href="//www.brooklynvegan.com/tags/fruit-bats/">Fruit Bats</a></span><span>, <a href="//www.brooklynvegan.com/tags/geoff-rickly/">Geoff Rickly</a></span><span>, <a href="//www.brooklynvegan.com/tags/gilt/">Gilt</a></span><span>, <a href="//www.brooklynvegan.com/tags/glassjaw/">Glassjaw</a></span><span>, <a href="//www.brooklynvegan.com/tags/godthrymm/">Godthrymm</a></span><span>, <a href="//www.brooklynvegan.com/tags/hard-girls/">Hard Girls</a></span><span>, <a href="//www.brooklynvegan.com/tags/hate-club/">Hate Club</a></span><span>, <a href="//www.brooklynvegan.com/tags/hinder/">hinder</a></span><span>, <a href="//www.brooklynvegan.com/tags/hiss-golden-messenger/">Hiss Golden Messenger</a></span><span>, <a href="//www.brooklynvegan.com/tags/hornbill/">Hornbill</a></span><span>, <a href="//www.brooklynvegan.com/tags/illuminati-hotties/">illuminati hotties</a></span><span>, <a href="//www.brooklynvegan.com/tags/indigo-girls/">Indigo Girls</a></span><span>, <a href="//www.brooklynvegan.com/tags/into-it-over-it/">Into It Over It</a></span><span>, <a href="//www.brooklynvegan.com/tags/jaime-brooks/">jaime brooks</a></span><span>, <a href="//www.brooklynvegan.com/tags/jeff-rosenstock/">Jeff Rosenstock</a></span><span>, <a href="//www.brooklynvegan.com/tags/jersey-interchange/">Jersey Interchange</a></span><span>, <a href="//www.brooklynvegan.com/tags/johanna-warren/">Johanna Warren</a></span><span>, <a href="//www.brooklynvegan.com/tags/josh-homme/">Josh Homme</a></span><span>, <a href="//www.brooklynvegan.com/tags/karl-blau/">Karl Blau</a></span><span>, <a href="//www.brooklynvegan.com/tags/ken-vandermark/">Ken Vandermark</a></span><span>, <a href="//www.brooklynvegan.com/tags/lakes/">Lakes</a></span><span>, <a href="//www.brooklynvegan.com/tags/lala-lala/">Lala Lala</a></span><span>, <a href="//www.brooklynvegan.com/tags/laughingstock/">Laughingstock</a></span><span>, <a href="//www.brooklynvegan.com/tags/lingua-ignota/">Lingua Ignota</a></span><span>, <a href="//www.brooklynvegan.com/tags/lucy-dacus/">Lucy Dacus</a></span><span>, <a href="//www.brooklynvegan.com/tags/macseal/">macseal</a></span><span>, <a href="//www.brooklynvegan.com/tags/michael-malarkey/">Michael Malarkey</a></span><span>, <a href="//www.brooklynvegan.com/tags/mike-hugenor/">Mike Hugenor</a></span><span>, <a href="//www.brooklynvegan.com/tags/mount-eerie/">Mount Eerie</a></span><span>, <a href="//www.brooklynvegan.com/tags/nathan-salsburg/">Nathan Salsburg</a></span><span>, <a href="//www.brooklynvegan.com/tags/nessa/">Nêssa</a></span><span>, <a href="//www.brooklynvegan.com/tags/nnamdi/">NNAMDI</a></span><span>, <a href="//www.brooklynvegan.com/tags/no-better/">No Better</a></span><span>, <a href="//www.brooklynvegan.com/tags/oceantor/">OCEANTOR</a></span><span>, <a href="//www.brooklynvegan.com/tags/odd-robot/">Odd Robot</a></span><span>, <a href="//www.brooklynvegan.com/tags/ogikubo-station/">Ogikubo Station</a></span><span>, <a href="//www.brooklynvegan.com/tags/ohmme/">OHMME</a></span><span>, <a href="//www.brooklynvegan.com/tags/otis-redding/">Otis Redding</a></span><span>, <a href="//www.brooklynvegan.com/tags/p-s-youredead/">p.s.you'redead</a></span><span>, <a href="//www.brooklynvegan.com/tags/palette-knife/">Palette Knife</a></span><span>, <a href="//www.brooklynvegan.com/tags/pet-symmetry/">Pet Symmetry</a></span><span>, <a href="//www.brooklynvegan.com/tags/petrol-girls/">Petrol Girls</a></span><span>, <a href="//www.brooklynvegan.com/tags/pink-navel/">Pink Navel</a></span><span>, <a href="//www.brooklynvegan.com/tags/pom-pom-squad/">pom pom squad</a></span><span>, <a href="//www.brooklynvegan.com/tags/post-animal/">Post Animal</a></span><span>, <a href="//www.brooklynvegan.com/tags/pronoun/">pronoun</a></span><span>, <a href="//www.brooklynvegan.com/tags/pylon/">Pylon</a></span><span>, <a href="//www.brooklynvegan.com/tags/queen-of-jeans/">Queen of Jeans</a></span><span>, <a href="//www.brooklynvegan.com/tags/radical-dads/">Radical Dads</a></span><span>, <a href="//www.brooklynvegan.com/tags/ramonda-hammer/">ramonda hammer</a></span><span>, <a href="//www.brooklynvegan.com/tags/ratboys/">Ratboys</a></span><span>, <a href="//www.brooklynvegan.com/tags/rem/">REM</a></span><span>, <a href="//www.brooklynvegan.com/tags/riverby/">Riverby</a></span><span>, <a href="//www.brooklynvegan.com/tags/rosie-tucker/">Rosie Tucker</a></span><span>, <a href="//www.brooklynvegan.com/tags/routine/">Routine</a></span><span>, <a href="//www.brooklynvegan.com/tags/sad13/">sad13</a></span><span>, <a href="//www.brooklynvegan.com/tags/sarah-and-the-safe-word/">Sarah and the Safe Word</a></span><span>, <a href="//www.brooklynvegan.com/tags/sean-bonnette/">Sean Bonnette</a></span><span>, <a href="//www.brooklynvegan.com/tags/sidney-gish/">Sidney Gish</a></span><span>, <a href="//www.brooklynvegan.com/tags/sonic-youth/">Sonic Youth</a></span><span>, <a href="//www.brooklynvegan.com/tags/spectral-voice/">Spectral Voice</a></span><span>, <a href="//www.brooklynvegan.com/tags/superchunk/">Superchunk</a></span><span>, <a href="//www.brooklynvegan.com/tags/swervedriver/">Swervedriver</a></span><span>, <a href="//www.brooklynvegan.com/tags/the-casket-lottery/">The Casket Lottery</a></span><span>, <a href="//www.brooklynvegan.com/tags/the-mountain-goats/">The Mountain Goats</a></span><span>, <a href="//www.brooklynvegan.com/tags/the-weekend-run-club/">The Weekend Run Club</a></span><span>, <a href="//www.brooklynvegan.com/tags/this-white-light/">This White Light</a></span><span>, <a href="//www.brooklynvegan.com/tags/titus-andronicus/">Titus Andronicus</a></span><span>, <a href="//www.brooklynvegan.com/tags/to-be-gentle/">To Be Gentle</a></span><span>, <a href="//www.brooklynvegan.com/tags/torres/">Torres</a></span><span>, <a href="//www.brooklynvegan.com/tags/two-minutes-to-late-night/">Two Minutes to Late Night</a></span><span>, <a href="//www.brooklynvegan.com/tags/will-butler/">Will Butler</a></span><span>, <a href="//www.brooklynvegan.com/tags/wye-oak/">Wye Oak</a></span><span>, <a href="//www.brooklynvegan.com/tags/you-me-and-everyone-we-know/">You Me and Everyone We Know</a></span><span>, <a href="//www.brooklynvegan.com/tags/zola-jesus/">Zola Jesus</a></span></div><div class="wrapper"><span>Categories<!-- -->: </span><span><a href="//www.brooklynvegan.com/category/music/">Music News</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down"></span></div><div class="cto">Leave A Comment</div></div></div><div class="lazyload-placeholder zergnet-lazyload-placeholder" data-pod="{}"></div><div class="goto-top-container outgrow"><a class="goto-top icon-triangle-left" href="javascript:void(0);" title="Go To Top" data-index="0">Back To Top</a></div></div></div></article></div></div></div></div><aside class="main-aside"><div class="aside-inside"><section class="sidebar-section widget-ts_blogroll" id="ts_blogroll-1388"><header><h2><span class="title-container">Check It Out</span></h2></header><div class="wrapper clearfix"><section id="ts_blogroll-1388" class="blogroll carousel slider dl align-right"><div class="slider blogroll-items"><div class="sizer"></div><div class="mover slide"><article class="item title-over-image"><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2019/06/coneyislandmermaidparade-2019-164.jpg" href="//www.brooklynvegan.com/the-2019-coney-island-mermaid-parade-in-pics/" rel="" title="RELIVE IT: The 2019 Coney Island Mermaid Parade in pics" data-source="blogroll"></a><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px"><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div class="content"><a href="//www.brooklynvegan.com/the-2019-coney-island-mermaid-parade-in-pics/" title="RELIVE IT: The 2019 Coney Island Mermaid Parade in pics" class="title" data-source="blogroll">RELIVE IT: The 2019 Coney Island Mermaid Parade in pics</a></div></article></div><div class="previous icon-arrow-thin-left arrow icon-base round always-visible" title="Previous"></div><div class="next icon-arrow-thin-right arrow icon-base round always-visible" title="Next"></div></div></section></div></section><section class="sidebar-section widget-fix_sidebar_marker" id="fix_sidebar_marker-46"><div class="wrapper clearfix"><div class="fix_sidebar_marker"></div></div></section><section class="sidebar-section widget-google-ads-widget" id="google-ads-widget-974"><div class="wrapper clearfix"><div class="widget-content"><div class="tsm-ad tsm-ad-300"><div id="tsm-ad-300a"><!-- dynamic ad --></div></div></div></div></section><section class="sidebar-section widget-promotion" id="promotion-16"><div class="wrapper clearfix"><div class="widget-content single"><article class="image-then-content"><figure class="frameme img-tag imgtag"><a class="theframe" data-image="//townsquare.media/site/838/files/2020/05/emaillist1.jpg" href="/newsletter-sign-up/" rel="" title="" data-source="promotion widget" target="_self"></a></figure><div class="content"><div class="carat"></div><div class="content-description"></div></div></article></div></div></section><section class="sidebar-section widget-ts_blogroll" id="ts_blogroll-1392"><header><h2><span class="title-container">Recent Stories</span></h2></header><div class="wrapper clearfix"><div class="widget-content blogroll-widget blogroll sidebar-thumb-title-date"><div class="blogroll-inner clearfix"><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2020/12/oh-santa-mariah-carey-1140x1140.jpeg" href="//www.brooklynvegan.com/17-new-holiday-songs-out-this-week/" rel="" title="17 New Holiday Songs Out This Week" data-source="blogroll"></a></figure><div class="content"><a href="//www.brooklynvegan.com/17-new-holiday-songs-out-this-week/" title="17 New Holiday Songs Out This Week" class="title" data-source="blogroll">17 New Holiday Songs Out This Week</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2020/12/robin-guthrie-harold-budd-another-flower.jpg" href="//www.brooklynvegan.com/listen-to-new-robin-guthrie-harold-budd-album-another-flower/" rel="" title="listen to new Robin Guthrie &amp;#038; Harold Budd album &amp;#8216;Another Flower&amp;#8217;" data-source="blogroll"></a></figure><div class="content"><a href="//www.brooklynvegan.com/listen-to-new-robin-guthrie-harold-budd-album-another-flower/" title="listen to new Robin Guthrie &amp; Harold Budd album ‘Another Flower’" class="title" data-source="blogroll">listen to new Robin Guthrie & Harold Budd album ‘Another Flower’</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2020/12/Comet-Is-Coming-Imminent.jpg" href="//www.brooklynvegan.com/36-new-songs-out-today-5/" rel="" title="36 New Songs Out Today" data-source="blogroll"></a></figure><div class="content"><a href="//www.brooklynvegan.com/36-new-songs-out-today-5/" title="36 New Songs Out Today" class="title" data-source="blogroll">36 New Songs Out Today</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2020/12/nickcave-pjharvey-collage-crop.jpg" href="//www.brooklynvegan.com/pj-harvey-reveals-drawings-nick-cave-made-for-her/" rel="" title="PJ Harvey reveals drawings Nick Cave made for her" data-source="blogroll"></a></figure><div class="content"><a href="//www.brooklynvegan.com/pj-harvey-reveals-drawings-nick-cave-made-for-her/" title="PJ Harvey reveals drawings Nick Cave made for her" class="title" data-source="blogroll">PJ Harvey reveals drawings Nick Cave made for her</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2018/11/diadelosdeftones-2018-54.jpg" href="//www.brooklynvegan.com/our-favorite-songs-of-the-week-playlist-deftones-sleaford-mods-more/" rel="" title="Our favorite songs of the week (playlist): Deftones, Sleaford Mods &amp;#038; more" data-source="blogroll"></a></figure><div class="content"><a href="//www.brooklynvegan.com/our-favorite-songs-of-the-week-playlist-deftones-sleaford-mods-more/" title="Our favorite songs of the week (playlist): Deftones, Sleaford Mods &amp; more" class="title" data-source="blogroll">Our favorite songs of the week (playlist): Deftones, Sleaford Mods & more</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2020/12/van-halen-guitar-auction.jpg" href="//www.brooklynvegan.com/wolfgang-van-halen-slams-rock-auction-selling-his-fathers-guitars/" rel="" title="Wolfgang Van Halen slams rock auction selling his father&amp;#8217;s guitars" data-source="blogroll"></a></figure><div class="content"><a href="//www.brooklynvegan.com/wolfgang-van-halen-slams-rock-auction-selling-his-fathers-guitars/" title="Wolfgang Van Halen slams rock auction selling his father’s guitars" class="title" data-source="blogroll">Wolfgang Van Halen slams rock auction selling his father’s guitars</a></div></article></div></div></div></section></div></aside></div><section class="site-footer"><footer><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a title="Home" href="/" aria-label="Home" class="">Home</a></li><li class=""><a title="About Us" href="/about-us" aria-label="About Us" class="">About Us</a></li><li class=""><a title="Contact Us" href="/contact-us" aria-label="Contact Us" class="">Contact Us</a></li><li class=""><a title="E-mail List Sign Up" href="/newsletter-sign-up" aria-label="E-mail List Sign Up" class="">E-mail List Sign Up</a></li><li class=""><a title="Privacy Policy" href="/privacy/" aria-label="Privacy Policy" class="">Privacy Policy</a></li><li class=""><a title="RSS" href="/feed" aria-label="RSS" class="">RSS</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link instagram" href="https://www.instagram.com/BrooklynVegan" target="_blank" data-social="instagram"><span class="icon-instagram"></span></a></li><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/brooklynvegan" target="_blank" data-social="youtube"><span class="icon-youtube"></span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/brooklynvegan" target="_blank" data-social="twitter"><span class="icon-twitter"></span></a></li><li class="social"><a class="share_link facebook" href="http://www.facebook.com/BrooklynVegan" target="_blank" data-social="facebook"><span class="icon-facebook"></span></a></li></ul></div></div><div class="legal">2020<!-- --> <!-- -->BrooklynVegan<!-- -->, <a href="http://www.townsquaremedia.com">Townsquare Media</a>, Inc. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            if(!window.TSM.fn.isIe(navigator.userAgent)){
              try{
                eval('(async function(){var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.faac599aae36a1b9701b044d93ab8f550b9cf1a3.js?mver=122"];for(var i=0;i<dependencies.length;i++){await getFile( dependencies[i] );}})();');
              }catch(e){console.error(e);}
            }else{
              document.write('<scr'+'ipt src="//townsquare.media/public/scripts.min.js?ver=faac599aae36a1b9701b044d93ab8f550b9cf1a3&mver=122"></sc'+'ript>');
            }
          })(document);</script>
          
        </body>
      </html>