<!doctype html>
      <html class="single desktop logo-above-nav fixed-full-width" lang="en">
        <head>
          <title>Ice Spice follows “Munch” with another new NY drill anthem, “Bikini Bottom”</title>
          <meta http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta charset="UTF-8"/><meta name="instagram_profile" value="BrooklynVegan"/><meta name="description" content="Ice Spice&#x27;s anticipated new single comes ahead of her appearance at Power 105.1&#x27;s Powerhouse with Nicki Minaj, Fivio Foreign, and more this weekend."/><meta name="keywords" content="hip hop news,music news"/><meta property="fb:app_id" content="598461367435921"/><meta property="fb:admins" content="100002025987268"/><meta property="fb:admins" content="590999851"/><meta property="fb:admins" content="100000461628108"/><meta property="fb:admins" content="732998853"/><meta property="fb:use_automatic_ad_placement" content="false"/><meta property="og:title" content="Ice Spice follows &#x22;Munch&#x22; with another new NY drill anthem, &#x22;Bikini Bottom&#x22;"/><meta property="og:description" content="Ice Spice&#x27;s anticipated new single comes ahead of her appearance at Power 105.1&#x27;s Powerhouse with Nicki Minaj, Fivio Foreign, and more this weekend."/><meta property="og:url" content="https://www.brooklynvegan.com/ice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom/"/><meta property="og:site_name" content="BrooklynVegan"/><meta property="og:type" content="article"/><meta property="og:image:width" content="1200"/><meta property="og:image:height" content="630"/><meta property="og:image" content="https://townsquare.media/site/838/files/2022/10/attachment-ice-spice-bikini-bottom.jpeg?w=1200&#x26;h=0&#x26;zc=1&#x26;s=0&#x26;a=t&#x26;q=89"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@brooklynvegan"/><meta name="robots" content="max-image-preview:large"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=6a5b34017ed6f04bee2a6f45f6c03974907e63a7&mver=132&gver=3" as="style"/><link rel="preload" href="//townsquare.media/public/dist/desktop/main.bundle.6a5b34017ed6f04bee2a6f45f6c03974907e63a7.js?mver=132&gver=3" as="script"/><link rel="preconnect" href="https://btloader.com" crossorigin /><link rel="preconnect" href="https://action.dstillery.com" crossorigin /><link rel="preconnect" href="https://px.owneriq.net" crossorigin /><link rel="preconnect" href="https://cdn.taboola.com" crossorigin />
          <link id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/838/files/2016/02/favicon.gif"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="prev" title="Indie Basement (10/28): the week in classic indie, college rock, and more" href="https://www.brooklynvegan.com/album-reviews-indie-basement-luke-haines-peter-buck-honey-harper-hammered-hulls-i-was-a-king-nancy-drugdealer/"/><link rel="canonical" href="https://www.brooklynvegan.com/ice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom/"/>
          <!-- <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" /> -->
          <!-- connect to domain of font files -->
          <link rel="preconnect" href="https://fonts.googleapis.com" crossorigin/>
          <!-- optionally increase loading priority -->
          <link rel="preload" as="style" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- async CSS -->
          <link rel="stylesheet" media="print" onload="this.onload=null;this.removeAttribute('media');" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          <!-- no-JS fallback -->
          <noscript>
            <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300%7CRoboto+Condensed:300,400,700&display=swap">
          </noscript>
          <link href="/styles/desktop/base.css?ver=6a5b34017ed6f04bee2a6f45f6c03974907e63a7&mver=132&gver=3" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
      window.TSM.fn.getCookie = window.TSM.fn.getCookie || function(n){var i="; "+document.cookie,t=i.split("; "+n+"=");if(t.length==2)return t.pop().split(";").shift()};
      window.TSM.fn.setCookie = window.TSM.fn.setCookie || function(n,t,i,r="/"){var f="",u;i&&(u=new Date,u.setTime(u.getTime()+i*864e5),f="; expires="+u.toUTCString());document.cookie=n+"="+(t||"")+f+"; path="+r};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "B";
          window.TSM.cadata = {"activeDomain":"www.brooklynvegan.com","blogId":838,"method":"get_single","postId":643776,"postType":"post","postDateGmt":"2022-10-28 13:09:21.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>(function(w,d){
        const
          getCookie = w.TSM.fn.getCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }
      })(window, document);</script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"asacher","dimension2":"hiphop,music","dimension3":"ice-spice","dimension4":"post","dimension5":"Fri Oct 28 2022","dimension6":"09:09","dimension7":"standard","dimension8":"711","dimension9":"B","dimension10":"no","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef"),window.opener&&window.opener.sessionStorage&&window.opener.sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
gaInitData.dimension15=window.aleph || "";
gaInitData.dimension16=navigator.userAgent || "";
window.globalDimensionData = {"dimension1":"asacher","dimension2":"hiphop,music","dimension3":"ice-spice","dimension4":"post","dimension5":"Fri Oct 28 2022","dimension6":"09:09","dimension7":"standard","dimension8":"711","dimension9":"B","dimension10":"no","dimension12":"","dimension13":"","dimension14":"","dimension15":"","dimension16":""};
window.globalDimensionData.dimension15=window.aleph || "";
ga( "create", {
          trackingId:"UA-1165436-1",
          name: "primary",
          allowAnchor: false
        });
        
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-1165436-1"};
            })(window);
          </script>
          <script async defer src="https://www.google-analytics.com/analytics.js"></script>
          <script async defer src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Ice Spice follows “Munch” with another new NY drill anthem, “Bikini Bottom”","callsign":"BrooklynVegan","market":"National","sitetype":"Partner","siteClassification":"","state":"NY","genre":"indie-alternative","pageType":"post","tags":"ice-spice","categories":"hiphop,music","mediaType":"video","aleph":"","userAgent":"","GaIds":"","GaPrimaryId":"","GaMarketRollupId":"","GaCompanyRollupId":"","GaRegionRollupId":"","GaStationRollupId":""}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");</script>
          
        <script>
        window.taskQ=window.taskQ||[];window.taskQ.push(function(){
          (function(w,dl){
            var
              isUS = RegExp( "us-region-source=CA" ).exec( document.cookie );
            const
              addOipScript = function(){
                if( dl && dl[0] ){
                  dl = dl[0];
                  w._oiqq = w._oiqq || [];
                  var keywordMeta = document.querySelector( "meta[name='keywords']");
                  _oiqq.push(["oiq_addPageBrand", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageBrand", "domain:" + location.hostname]);
                  _oiqq.push(["oiq_addPageBrand", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "url_path:" + location.pathname]);
                  _oiqq.push(["oiq_addPageCat", "meta_keywords:" + ( keywordMeta ? keywordMeta.content : "" ) ]);
                  _oiqq.push(["oiq_addPageCat", "title:" + dl.title]);
                  _oiqq.push(["oiq_addPageCat", "callsign:" + dl.callsign]);
                  _oiqq.push(["oiq_addPageCat", "market:" + dl.market]);
                  _oiqq.push(["oiq_addPageCat", "sitetype:" + dl.sitetype]);
                  _oiqq.push(["oiq_addPageCat", "state:" + dl.state]);
                  _oiqq.push(["oiq_addPageCat", "page_type:" + dl.pageType]);
                  _oiqq.push(["oiq_addPageCat", "media_type:" + dl.mediaType]);
                  _oiqq.push(["oiq_addPageCat", "day_of_week:" + dl.dayOfWeek]);
                  _oiqq.push(["oiq_addPageCat", "newsletter_submission:" + (dl.newsletterSubmission || "no")]);
                  _oiqq.push(["oiq_addPageCat", "period_of_day:" + dl.periodOfDay]);
                  _oiqq.push(["oiq_addPageCat", "curated_referer:" + dl.curatedReferer]);
                  _oiqq.push(["oiq_addPageCat", "genre:" + dl.genre]);
                  _oiqq.push(["oiq_addPageCat", "tags:" + dl.tags]);
                  _oiqq.push(["oiq_addPageCat", "categories:" + dl.categories]);
                  _oiqq.push(["oiq_doTag"]);
                  _oiqq.push(["oiq_addPageLifecycle", "ecv3"]);
                }
                var oiq = document.createElement("script"); oiq.type = "text/javascript"; oiq.async = true; oiq.defer = true;
                oiq.src = document.location.protocol + "//px.owneriq.net/stas/s/0frxgz.js";
                var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(oiq, s);
              },
              callback =  (tcData, success) => {
                if(success && tcData.eventStatus === 'tcloaded') {
                  if( !tcData.gdprApplies || ( tcData.gdprApplies && tcData.tcString ) ){
                    addOipScript();
                  }
                  __tcfapi('removeEventListener', 2, (success) => {}, tcData.listenerId );
                }
              };
            __tcfapi( "addEventListener", 2, callback );
          })(window, window.dataLayer);
        });
      </script>
        
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = 'https://btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=BrooklynVegan&ncv=24", {"async": "async", "defer": "defer"});
        window.TSM.fn.getFile("https://action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=all_tsm_sv&ncv=24", {"async": "async", "defer": "defer"});
      });</script>
        
        
        
        <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//townsquare.media/public/resources/js/pubcid.min.js';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:336};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <link rel="preconnect" href="https://d3c6l876mn6xxv.cloudfront.net." crossorigin/><script type="text/javascript" src="//d3c6l876mn6xxv.cloudfront.net./script.js" async></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>
<script async src="//js-sec.indexww.com/ht/p/186854-113710634486999.js"></script>
<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=www.brooklynvegan.com&v=6a5b34017ed6f04bee2a6f45f6c03974907e63a7&mver=132&gver=3" ></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script type="text/javascript" async defer src="//assets.pinterest.com/js/pinit.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "www.brooklynvegan.com";ZERG.user = 751;</script>
          <script type="text/javascript">
      window._taboola = window._taboola || [];
        _taboola.push({article:"auto"});
        !function (e, f, u, i) {
          if (!document.getElementById(i)){
            e.async = 1;
            e.src = u;
            e.id = i;
            f.parentNode.insertBefore(e, f);
          }
        }(document.createElement("script"),
          document.getElementsByTagName("script")[0],
          "//cdn.taboola.com/libtrc/townsquaremediatsm-network/loader.js",
          "tb_loader_script");
        if(window.performance && typeof window.performance.mark == "function")
        {window.performance.mark("tbl_ic");}
    </script>
          <script type="application/ld+json">{"@context":"https://schema.org","@graph":[{"@context":"https://schema.org/","@type":"NewsMediaOrganization","@id":"https://www.brooklynvegan.com/#organization","name":"Brooklyn Vegan","logo":{"@type":"ImageObject","@id":"https://www.brooklynvegan.com/#sitelogo","url":"//townsquare.media/site/838/files/2015/12/bv-1logo-new1.png"},"sameAs":["https://www.brooklynvegan.com/"]},{"@context":"http://schema.org/","@type":"Website","@id":"https://www.brooklynvegan.com/#website","publisher":{"@id":"https://www.brooklynvegan.com/#organization"},"name":"Brooklyn Vegan","url":"https://www.brooklynvegan.com/"},{"@context":"https://schema.org","@type":"article","headline":"Ice Spice follows \"Munch\" with another new NY drill anthem, \"Bikini Bottom\"","publisher":{"@id":"https://www.brooklynvegan.com/#organization"},"url":"https://www.brooklynvegan.com/ice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.brooklynvegan.com/ice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom/"},"description":"Ice Spice's anticipated new single comes ahead of her appearance at Power 105.1's Powerhouse with Nicki Minaj, Fivio Foreign, and more this weekend.","@id":"https://www.brooklynvegan.com/ice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom/#article","image":"//townsquare.media/site/838/files/2022/10/attachment-ice-spice-bikini-bottom.jpeg","author":{"@type":"Person","name":"Andrew Sacher","sameAs":"https://www.brooklynvegan.com/author/asacher"},"keywords":["hip hop news","music news"],"datePublished":"2022-10-28T13:09:21.000Z","dateCreated":"2022-10-28T13:09:21.000Z","dateModified":"2022-10-28T13:09:21.000Z","isPartOf":{"@id":"https://www.brooklynvegan.com/#website"}}]}</script>
        </head>
        <body>
          <script>(function(w,d){
        const
          getCookie = window.TSM.fn.getCookie,
          setCookie = window.TSM.fn.setCookie;
        let
          aleph = getCookie( "aleph" );
        if( aleph ){
          w.aleph = aleph;
        }else{
          w.addEventListener("message", (e) => {
            //console.log(e);
            if( e.data && e.data.aleph ){
              //console.log( "e.data.aleph", e.data.aleph );
              window.aleph = e.data.aleph;
              window.cQ = window.cQ || [];
              window.cQ.push(()=>{
                window.globalActionCreators && window.globalActionCreators.addAleph && window.globalActionCreators.addAleph( window.aleph )
              });
              setCookie( "aleph", e.data.aleph, 365*2 );
            }
          });
          let
            ifr = d.createElement( "iframe" );
          ifr.id = "aleph-iframe";
          ifr.title = "aleph";
          ifr.src = "https://cdn.production.townsquareblogs.com/aleph/";
          ifr.frameborder = "0";
          ifr.style = "display:none;"
          ifr.addEventListener("load", ()=>{
            ifr.contentWindow.postMessage({action: "getAleph"}, "https://cdn.production.townsquareblogs.com");
          });
          d.body.appendChild( ifr );
        }
      })(window, document);</script>
          <div id="fb-root"></div>
          <div id="app">
          <div><header id="site-menu-wrapper" class="no-showticker leaderboard-style-default" aria-label="site header"><div id="skip-to-main"><a href="#main-content">Skip to main content</a><a href="#site-footer">Skip to site footer</a></div><div class="site-menu-drawer"><ul class="promo-links" aria-label="promoted links"><li><span>Trending:</span></li><li><a href="https://shop.brooklynvegan.com/?from=trending">Shop Records, Merch &amp; More</a></li><li><a href="https://brooklynvegan.podbean.com/">BrooklynVegan Podcast</a></li><li><a href="/tags/new-songs/?from=trending">New Songs</a></li><li><a href="/category/contests/">Contests</a></li><li><a href="/category/to-do/">What&#x27;s Going on Tonight in NYC?</a></li><li><a href="/87-albums-were-anticipating-for-fall-2022/">87 albums we&#x27;re anticipating for fall 2022</a></li></ul></div><div id="site-menu-bg"></div><div class="next-to-logo"><div class="non-menu-content"><a class="logo" itemProp="logo url" href="/" data-source="logo"><img src="//townsquare.media/site/838/files/2017/10/bv-1logo-new1.png" alt="BrooklynVegan"/></a><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow" aria-label="primary navigation"><div class="wrapper"><ul class="links"><li class="hassub"><a href="/" data-source="nav">Home</a></li><li class="hassub"><a href="/category/music/" data-source="nav">Music</a></li><li class="hassub"><a href="/category/metal/" data-source="nav">Metal</a><ul class="links submenu"><li class="hassub"><a href="/category/metal/" data-source="nav">BV Metal News</a></li><li class="hassub"><a href="http://invisibleoranges.com" data-source="nav" target="_blank">Invisible Oranges</a></li><li class="hassub"><a href="http://www.invisibleoranges.com/metal-show-listings/" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub"><a href="/tags/punk" data-source="nav">Punk</a></li><li class="hassub"><a href="/category/music/hiphop" data-source="nav">Rap</a></li><li class="hassub"><a href="/category/music/dance" data-source="nav">Dance</a></li><li class="hassub"><a href="/category/comedy" data-source="nav">Comedy</a><ul class="links submenu"><li class="hassub"><a href="/category/comedy" data-source="nav">Comedy News</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/events/comedy" data-source="nav" target="_blank">NYC Comedy Calendar</a></li></ul></li><li class="hassub"><a href="/category/movies" data-source="nav">Movies</a></li><li class="hassub"><a href="/category/music/tour-dates/" data-source="nav">Tours</a></li><li class="hassub"><a href="/category/to-do" data-source="nav">Listings</a><ul class="links submenu"><li class="hassub"><a href="/category/to-do" data-source="nav">What&#x27;s Going On (NYC)</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/brooklynveganpresents" data-source="nav" target="_blank">BV Presents Events</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com" data-source="nav" target="_blank">NYC Show Calendar</a></li><li class="hassub"><a href="http://chicago-shows.brooklynvegan.com/" data-source="nav" target="_blank">Chicago Show Calendar</a></li><li class="hassub"><a href="http://austin-shows.brooklynvegan.com/" data-source="nav" target="_blank">Austin Show Calendar</a></li><li class="hassub"><a href="https://www.invisibleoranges.com/metal-show-listings/" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub"><a href="https://shop.brooklynvegan.com/" data-source="nav" target="_blank">SHOP</a></li><li class="hassub"><a href="/contact-us" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/contact-us" data-source="nav">Contact</a></li><li class="hassub"><a href="/about-us" data-source="nav">About Us</a></li><li class="hassub"><a href="/newsletter-sign-up" data-source="nav">Newsletter Sign-up</a></li></ul></li><li class="hidden-menu hassub hide"><div class="more-icon link" aria-hidden="true">More</div><ul class="links submenu"><li class="hassub hide"><a href="/" data-source="nav">Home</a></li><li class="hassub hide"><a href="/category/music/" data-source="nav">Music</a></li><li class="hassub hide"><a href="/category/metal/" data-source="nav">Metal</a><ul class="links submenu"><li class="hassub"><a href="/category/metal/" data-source="nav">BV Metal News</a></li><li class="hassub"><a href="http://invisibleoranges.com" data-source="nav" target="_blank">Invisible Oranges</a></li><li class="hassub"><a href="http://www.invisibleoranges.com/metal-show-listings/" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub hide"><a href="/tags/punk" data-source="nav">Punk</a></li><li class="hassub hide"><a href="/category/music/hiphop" data-source="nav">Rap</a></li><li class="hassub hide"><a href="/category/music/dance" data-source="nav">Dance</a></li><li class="hassub hide"><a href="/category/comedy" data-source="nav">Comedy</a><ul class="links submenu"><li class="hassub"><a href="/category/comedy" data-source="nav">Comedy News</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/events/comedy" data-source="nav" target="_blank">NYC Comedy Calendar</a></li></ul></li><li class="hassub hide"><a href="/category/movies" data-source="nav">Movies</a></li><li class="hassub hide"><a href="/category/music/tour-dates/" data-source="nav">Tours</a></li><li class="hassub hide"><a href="/category/to-do" data-source="nav">Listings</a><ul class="links submenu"><li class="hassub"><a href="/category/to-do" data-source="nav">What&#x27;s Going On (NYC)</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com/brooklynveganpresents" data-source="nav" target="_blank">BV Presents Events</a></li><li class="hassub"><a href="http://nyc-shows.brooklynvegan.com" data-source="nav" target="_blank">NYC Show Calendar</a></li><li class="hassub"><a href="http://chicago-shows.brooklynvegan.com/" data-source="nav" target="_blank">Chicago Show Calendar</a></li><li class="hassub"><a href="http://austin-shows.brooklynvegan.com/" data-source="nav" target="_blank">Austin Show Calendar</a></li><li class="hassub"><a href="https://www.invisibleoranges.com/metal-show-listings/" data-source="nav" target="_blank">Metal Show Calendars</a></li></ul></li><li class="hassub hide"><a href="https://shop.brooklynvegan.com/" data-source="nav" target="_blank">SHOP</a></li><li class="hassub hide"><a href="/contact-us" data-source="nav">Contact</a><ul class="links submenu"><li class="hassub"><a href="/contact-us" data-source="nav">Contact</a></li><li class="hassub"><a href="/about-us" data-source="nav">About Us</a></li><li class="hassub"><a href="/newsletter-sign-up" data-source="nav">Newsletter Sign-up</a></li></ul></li></ul></li></ul><div class="site-menu-right"><ul class="social-links"><li class="social"><a class="share-link youtube" href="https://youtube.com/user/brooklynvegan" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/BrooklynVegan" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/brooklynvegan" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li><li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/BrooklynVegan" target="_blank" rel="noopener noreferrer">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></li></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></header><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-oop2"><!-- dynamic ad --></div></div></div></div><div><!-- below-nav-970x50 slot inactive --></div><div class="container-inner"><div class="site-content clearfix"><main id="main-content" class="main-content" tabindex="-1"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-643776" data-location="/ice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-643776"><div class="content-header-header"><div class="react-parallax"><figure class="frameme temp-ssr" alt="Ice Spice follows &amp;#8220;Munch&amp;#8221; with another new NY drill anthem, &amp;#8220;Bikini Bottom&amp;#8221;"><img src="https://townsquare.media/site/838/files/2022/10/attachment-ice-spice-bikini-bottom.jpeg?w=980&amp;q=75" alt="Ice Spice follows &amp;#8220;Munch&amp;#8221; with another new NY drill anthem, &amp;#8220;Bikini Bottom&amp;#8221;"/></figure></div><div class="header"><section class="title "><h1 class="">Ice Spice follows “Munch” with another new NY drill anthem, “Bikini Bottom”</h1></section><div class="byline"><div class="author-image"><div class="icon-user" aria-hidden="true"></div><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/06/attachment-andrew-2.jpeg" href="//www.brooklynvegan.com/author/asacher/" rel="author"><figcaption class="visually-hidden">Andrew Sacher</figcaption></a></figure></div><div class="not-author-image-stuff"><div class="not-author-image-stuff-row"><a class="author-name" href="//www.brooklynvegan.com/author/asacher/" rel="author">Andrew Sacher</a><time dateTime="2022-10-28 13:09:21 +0000">Published: October 28, 2022</time></div></div></div></div></div></div></div><div class="content-wrap"><div class="social-share bignsexy"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.brooklynvegan.com%2Fice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom%2F%3Ftrackback%3Dfbshare_mobile" title="SHARE" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">SHARE</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Ice%20Spice%20follows%20%E2%80%9CMunch%E2%80%9D%20with%20another%20new%20NY%20drill%20anthem%2C%20%E2%80%9CBikini%20Bottom%E2%80%9D%20http%3A%2F%2Fwww.brooklynvegan.com%2Fice-spice-follows-munch-with-another-new-ny-drill-anthem-bikini-bottom%2F%3Ftrackback%3Dtwitter_mobile%20%40brooklynvegan" title="TWEET" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">TWEET</span></span></a></li></ul></div></div><div class="content"><div class="pod-content"><p><b>Ice Spice</b>&apos;s <a href="https://www.brooklynvegan.com/24-new-songs-out-today-40/">&quot;Munch (Feelin&apos; U)&quot;</a> quickly became the New York drill anthem of the summer, and today she follows that song with another new single, &quot;Bikini Bottom.&quot; Like &quot;Munch,&quot; it was produced by RIOTUSA, and right now it looks like &quot;Munch&quot; was no fluke. This is yet another instantly-satisfying drill anthem and it&apos;s keeping us very excited to hear what Ice Spice does next. Check it out below.</p><p>Ice Spice plays <a href="https://www.brooklynvegan.com/nicki-minaj-headlining-power-105-1s-powerhouse-w-moneybagg-yo-fivio-foreign-more/">Power 105.1&apos;s Powerhouse</a> in Newark this Saturday (10/29) with Nicki Minaj, Kodak Back, Moneybagg Yo, TEMS, and Fivio Foreign. Ice Spice also joined Fivio on stage at the recent <a href="https://www.brooklynvegan.com/rolling-loud-ny-recap-kanye-nicki-minaj-aap-rocky-glorilla-ice-spice-fivio-foreign-more/">Rolling Loud NYC</a> (where Fivio also joined Nicki during her set).</p><div class="in-article-oop-container"><div class="tsm-ad tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop" aria-label="advertisement"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><div class="lazyload-placeholder oembed-lazyload-placeholder"></div></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper tags"><span>Filed Under<!-- -->: </span><span><a href="//www.brooklynvegan.com/tags/ice-spice/">Ice Spice</a></span></div><div class="wrapper categories"><span>Categories<!-- -->: </span><span><a href="//www.brooklynvegan.com/category/music/hiphop/">Hip Hop news</a></span><span>, <a href="//www.brooklynvegan.com/category/music/">Music News</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down" aria-hidden="true"></span></div><div class="cto">Leave A Comment</div></div></div></div></div></article><div class="tsm-ad tsm-ad-728 tsm-ad-in-between-article" aria-label="advertisement"><div id="tsm-ad-728c-1"><!-- dynamic ad --></div></div><section id="ts_blogroll-afterpost" class="blogroll row-standard-3x ts_blogroll outgrow"><header class="header-band"><h2 class="">More From Brooklyn Vegan</h2></header><div class="blogroll-inner clearfix"><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/09/attachment-rollingloud-2022-038.jpg" href="/nicki-minaj-headlining-power-105-1s-powerhouse-w-moneybagg-yo-fivio-foreign-more/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Nicki Minaj headlining Power 105.1&#8217;s Powerhouse w/ Moneybagg Yo, Fivio Foreign &#038; more</figcaption></a></figure><div class="content"><a href="/nicki-minaj-headlining-power-105-1s-powerhouse-w-moneybagg-yo-fivio-foreign-more/" class="title" data-source="blogroll">Nicki Minaj headlining Power 105.1&#8217;s Powerhouse w/ Moneybagg Yo, Fivio Foreign &#038; more</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/09/attachment-asap-rocky-rolling-loud.jpeg" href="/rolling-loud-ny-recap-kanye-nicki-minaj-aap-rocky-glorilla-ice-spice-fivio-foreign-more/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Rolling Loud NY recap &#038; pics: Kanye, Nicki Minaj, A$AP Rocky &#038; GloRilla, Ice Spice &#038; Fivio Foreign, more</figcaption></a></figure><div class="content"><a href="/rolling-loud-ny-recap-kanye-nicki-minaj-aap-rocky-glorilla-ice-spice-fivio-foreign-more/" class="title" data-source="blogroll">Rolling Loud NY recap &#038; pics: Kanye, Nicki Minaj, A$AP Rocky &#038; GloRilla, Ice Spice &#038; Fivio Foreign, more</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/09/attachment-nick-hakim.jpeg" href="/tour-news-nick-hakim-katatonia-janis-ian-patterson-hood-mike-cooley-more/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Tour news: Nick Hakim, Katatonia, Janis Ian, Patterson Hood &#038; Mike Cooley, more</figcaption></a></figure><div class="content"><a href="/tour-news-nick-hakim-katatonia-janis-ian-patterson-hood-mike-cooley-more/" class="title" data-source="blogroll">Tour news: Nick Hakim, Katatonia, Janis Ian, Patterson Hood &#038; Mike Cooley, more</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/08/attachment-DANGER-MOUSE-BLACK-THOUGHT.jpg" href="/our-favorite-songs-of-the-week-playlist-75/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Our favorite songs of the week (playlist)</figcaption></a></figure><div class="content"><a href="/our-favorite-songs-of-the-week-playlist-75/" class="title" data-source="blogroll">Our favorite songs of the week (playlist)</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/08/attachment-braids-retriever.jpeg" href="/24-new-songs-out-today-40/" rel="" data-source="blogroll"><figcaption class="visually-hidden">24 New Songs Out Today</figcaption></a></figure><div class="content"><a href="/24-new-songs-out-today-40/" class="title" data-source="blogroll">24 New Songs Out Today</a></div></article><article class=""><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/838/files/2022/06/attachment-BONNIE-PRINCE-BILLY.jpeg" href="/tour-news-bonnie-prince-billy-giveon-thrice-sarah-shook-anti-flag-more/" rel="" data-source="blogroll"><figcaption class="visually-hidden">Tour news: Bonnie &#8220;Prince&#8221; Billy, Giveon, Thrice, Sarah Shook, Anti-Flag, more</figcaption></a></figure><div class="content"><a href="/tour-news-bonnie-prince-billy-giveon-thrice-sarah-shook-anti-flag-more/" class="title" data-source="blogroll">Tour news: Bonnie &#8220;Prince&#8221; Billy, Giveon, Thrice, Sarah Shook, Anti-Flag, more</a></div></article></div></section></div></div></div></main><aside class="main-aside" aria-label="sidebar"></aside></div><section class="site-footer"><footer id="site-footer" tabindex="-1"><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a href="/" aria-label="Home">Home</a></li><li class=""><a href="/about-us" aria-label="About Us">About Us</a></li><li class=""><a href="/contact-us" aria-label="Contact Us">Contact Us</a></li><li class=""><a href="/newsletter-sign-up" aria-label="E-mail List Sign Up">E-mail List Sign Up</a></li><li class=""><a href="/privacy/" aria-label="Privacy Policy">Privacy Policy</a></li><li class=""><a href="/feed" aria-label="RSS">RSS</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link youtube" href="https://www.youtube.com/user/brooklynvegan" target="_blank" rel="noopener noreferrer" data-social="youtube"><span class="visually-hidden">Visit us on Youtube</span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/BrooklynVegan" target="_blank" rel="noopener noreferrer" data-social="facebook"><span class="visually-hidden">Visit us on Facebook</span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/brooklynvegan" target="_blank" rel="noopener noreferrer" data-social="twitter"><span class="visually-hidden">Visit us on Twitter</span></a></li></ul></div></div><div class="legal">2022<!-- --> <!-- -->BrooklynVegan<!-- -->. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728" aria-label="advertisement"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div><div><!-- interstitial slot inactive --></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          
          
          
          
          
          
          
          
          
          
          
          <script type="text/javascript">
      window._taboola = window._taboola || [];
      _taboola.push({flush: true});
    </script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            try{
              let
                getDependencies = function(){
                  return new Promise(async function( res, rej ){
                    var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.6a5b34017ed6f04bee2a6f45f6c03974907e63a7.js?mver=132&gver=3"];
                    for(var i=0;i<dependencies.length;i++){
                      await getFile( dependencies[i] );
                    }
                    res({});
                  });
                },
                getInitialState = function(){
                  return fetch( [ location.pathname, location.search, ( location.search ? "&" : "?" ), "initialState=6a5b34017ed6f04bee2a6f45f6c03974907e63a7" ].join( "" ) )
                    .then( response => {
                      if( !response.ok ){
                        if( response.status === 404 ){
                          return response;
                        }
                        throw Error( response.statusText );
                      }
                      return response;
                    })
                    .then( response => response.json() )
                    .catch(( err )=>{
                      console.log( "Carbon - Error in Rest response", err );
                    });
                };
              let allTasks = [ getDependencies() ];Promise.all( allTasks )
                  .then(function(results){
                    window.initCarbon && window.initCarbon();
                  });
            }catch(e){console.error(e);}
          })(document);</script>
          
        </body>
      </html>